POJ1948 Triangular Pastures(DP)

题目来源:
http://poj.org/problem?id=1948
Description
Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 
I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 
Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 
Input
* Line 1: A single integer N 
* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 
Output
A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 
Sample Input
5
1
1
3
3
4
Sample Output
692
Hint
[which is 100x the area of an equilateral triangle with side length 4] 
思路:
http://www.cnblogs.com/gj-Acit/p/3440507.html
题目大意就是说给你n个木棍让你用它们摆成一个三角形  使得这个三角形的面积最大。
先求出通过这n个木棍可以构成哪些边长组合的三角形,最后再一一比较这些三角形的面积。
代码:

(自己修改上面网址代码后的代码,便于理解)

#include <iostream>
using namespace std;
#include <cmath>

bool DP[880][880]; //能够构成的两条边长 
int len[42], tot, N;

bool Judge(int a,int b,int c)
{
	if(a+b>c && a+c>b && b+c>a) return true;
	return false;
}

double area(int a, int b, int c)
{
	double p = (double)(a+b+c)/2.0;
	return sqrt(p*(p-a)*(p-b)*(p-c)); //求面积公式
}

int main()
{
	int i,j,k;
	while(cin>>N){
		for(i=0;i<N;i++)
		{
			cin>>len[i];
			tot += len[i];
		}
		int half = tot/2;
		DP[0][0] = 1;
		for( k=0;k<N;k++){
			for( i=half;i>=0;i--){ //边长小于总长一半,必须是从大到小进行,不然一条边会被放多次
				for( j=half;j>=0;j--){
					if((i-len[k]>=0 && DP[i-len[k]][j]) || (j-len[k]>=0 &&DP[i][j-len[k]])){
						DP[i][j]=1;
					}
				}
			}
		}
		double ans = -1;
		for( i=0;i<=half;i++)
			for( j=0;j<=half;j++)
				if(DP[i][j] && Judge(i,j,tot-i-j))
					ans = max(ans, 100*area(i,j,tot-i-j));
		cout<<(int)ans<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值