Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 96654 Accepted Submission(s): 36907
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5 green red blue red red 3 pink orange pink 0
Sample Output
red pink
//此题主要是考察对二维数组的行数组运用
#include<stdio.h>
#include<string.h>
int main()
{
char color[1005][10];//将每种颜色都放到一个字符数组中
int i,j,n;
while(~scanf("%d",&n)&&n)
{
int a[1005]={0};
for(i=0;i<n;i++)
{
scanf("%s",color[i]);//循环输入
}
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)//也是从0开始,因为第一个也要加1
{
if(strcmp(color[i],color[j])==0)//字符串的比较
{
a[i]++;
}
}
}
int max=0;//寻找最大值所在下标
for(i=1;i<n;i++)
{
if(a[max]<a[i])
max=i;
}
printf("%s\n",color[max]);
}
}
#include<stdio.h>
#include<string.h>
int main()
{
char color[1005][10];//将每种颜色都放到一个字符数组中
int i,j,n;
while(~scanf("%d",&n)&&n)
{
int a[1005]={0};
for(i=0;i<n;i++)
{
scanf("%s",color[i]);//循环输入
}
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)//也是从0开始,因为第一个也要加1
{
if(strcmp(color[i],color[j])==0)//字符串的比较
{
a[i]++;
}
}
}
int max=0;//寻找最大值所在下标
for(i=1;i<n;i++)
{
if(a[max]<a[i])
max=i;
}
printf("%s\n",color[max]);
}
}