uva 10106(高精度)

题目:

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

output

For each input pair of lines the output line should consist one integer the product.

sample input

12

12

2

222222222222222222

sample output

144

444444444444444444

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
const int N = 1005;

int main(){
	int m, n;
	char str1[N], str2[N];
	int ans[N];
	while (scanf("%s %s", str1, str2) != EOF) {
		memset(ans, 0, sizeof(ans));
		n = m = 0;
		int i, k;
		int len1 = strlen(str1);
		int len2 = strlen(str2);
		for (k = len2 - 1; k >= 0; k--) {
			for (i = len1 - 1; i >= 0; i--) {
				int temp1 = ans[n] + ((str1[i] - '0') * (str2[k] - '0')); 
				ans[n] = temp1 % 10;
				n++;
				ans[n] = ans[n] +  temp1 / 10;
				if (ans[n] > 9) {
					int temp2 = ans[n];
					ans[n] = temp2 % 10;
					ans[n + 1] = ans[n + 1] + temp2 / 10;
				}
			}
			m++;
			n = m;
		}
		for (i = N - 1; i >= 0; i--)
			if (ans[i] != 0)
				break;
		if (i == -1)
			cout << "0";
		else
			for (int j = i; j >= 0; j--)
				cout << ans[j];
		cout << endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值