uva 644(字符串)

题目:

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

input

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

sample input

01

10

0010

0000

9

01

10

010

0000

9

sample output


Set 1 is immediately decodable
Set 2 is not immediately decodable

题解:如果存在一个二进制码是另一个二进制码的前缀(或是相同的),就输出is not immediately decodable,否则输出immediately decodable,按字典排序,然后短的和长的码对比得到结果。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char str[200][200];

int cmp(const void * s1,const void * s2) {
     return strcmp((char *)s1, (char *)s2);
}

int judge(int length1, int j) {
	for (int q = 0; q < length1; q++)
		if (str[j][q] != str[j + 1][q])
			return 0;
	return 1;
}

int main(){
	int k = 0, i, t = 1;
	memset(str, '\0', sizeof(str));
	while (~scanf("%s", str[k])) {
		if (str[k][0] != '9') {
			k++;
			continue;
		}
			qsort(str, k, sizeof(str[0]), cmp);
			for (i = 0; i < k - 1; i++) {
				int len1 = strlen(str[i]);
				int len2 = strlen(str[i + 1]);
				if (len1 <= len2) {
					int flag = judge(len1, i);
					if (flag == 1) {
						cout << "Set " << t++ << " is not immediately decodable" << endl;
						break;
					}
				}
			}
			if (i == k - 1)
				cout << "Set " << t++ << " is immediately decodable" << endl;
			k = 0;
			memset(str, '\0', sizeof(str));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值