uva644 - Immediate Decodability

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable

前缀编码,由于数据很小直接穷举每一种判断即可,开始以为可以只判断一半,但是因为判断的时候有个长度的条件,所以相反的情况还是要判断还是n*n次,不能n*n/2;

while (scanf("%s",&s[sum])==1),scanf的返回值是读入值的个数,所以当没有数据读入时为0就结束了。后来用eof交了下也可以╮(╯▽╰)╭不能·太依赖别人的code。

#include <stdio.h>
#include <string.h>
void main ()
{char s[10][10];
 int num=0,l1,l2,flag,i,j,k,sum=0,a[10];
 while (scanf("%s",&s[sum])==1)
 {
  while (scanf("%s",&s[sum+1]))
  if (s[sum+1][0]=='9') break;
                   else ++sum;
  for (i=0;i<=sum;i++)
  a[i]=strlen(s[i]);
 
  for (i=0;i<=sum;i++)
  {
   for (j=0;j<=sum;j++)
   {flag=1;
 if ((i!=j)&&(a[j]>=a[i]))
 {for (k=0;k<a[i];k++)
  if (s[i][k]!=s[j][k]) {flag=0; break;}
 }
 else flag=0;
    if (flag) goto there ; 
   }
  }
  there : ;
  sum=0;
  ++num;
  if (flag) printf("Set %d is not immediately decodable\n",num);
       else printf("Set %d is immediately decodable\n",num);
 }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值