uva 340(检索)

题目:

MasterMind is a game for two players. One of them,Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the lengthN that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guesstex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j),tex2html_wrap_inline41 andtex2html_wrap_inline43 , such thattex2html_wrap_inline45 . Match (i,j) is calledstrong when i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are calledindependent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

input 

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum value for N will be 1000.

output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

sample input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

sample output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)

题解:每个数列都和第一个对比,相对位置相同的坐标x++,数字相同但位置不同的坐标y++,一个数字只能被找到一次且位置相同的优先级更高,输出时括号前的空格不要忘记。。


#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1005;
int main(){
	int n, s[N][N], num, flag1, flag2, temp[N], temp1[N];
	int i, j, k, l, t = 1;
	while (~scanf("%d", &n) && n) {
		num = flag1 = flag2 = 0;
		memset(temp1, 0, sizeof(temp1));
		while (1) {
			for (int i = 0; i < n; i++)
				cin >> s[num][i];
			if (s[num][0] == 0)
				break;
			else
				num++;
		}
		for (i = 0; i < n; i++) {
			temp1[i] = 0;
			temp[i] = s[0][i];
		}
		cout << "Game " << t++ << ":" << endl;
		for (i = 1; i < num; i++) {
			for (j = 0; j < n; j++)
			//	cout << temp[j] << endl;
				if (s[i][j] == temp[j]) {
					temp1[j] = 1;
					flag1++;
					temp[j] = 10;
				}
			for (l = 0; l < n; l++)
				for (k = 0; k < n; k++) 
					if (temp1[l] == 0 && s[i][l] == temp[k]) {
			//			cout << temp[k] << endl;
						flag2++;
						temp[k] = 10;//将已经对应的位置上的数改掉,下次就不会被匹配
						temp1[l] = 1;
					}
					else if (temp1[l] == 1)
						break;
			cout << "    (" << flag1 << "," << flag2 << ")" << endl;
			flag1 = flag2 = 0;
			for (l = 0; l < n; l++) {
				temp[l] = s[0][l];
				temp1[l] = 0;
			}
		}	
		memset(s, -1, sizeof(s));
		memset(temp, -1, sizeof(s));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值