uva340

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=276

340 - Master-Mind Hints

Time limit: 3.000 seconds

Master-Mind Hints

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 , such that tex2html_wrap_inline45 . Match (i,j) is called strong when i = j, and is called weakotherwise. Two matches (i,j) and (p,q) are called independentwhen i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as Nintegers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for Nwould normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)
题意:英文完全看不懂。。其实就是给你一组数据,然后你输入数据,和给定的数据进行比较,如果有当s1i==s2j&&i==j的时候A++,如果s1i!=s2j&&i!=j的时候B++,但是还有一个条件A++优先于B++,就是说当A++条件成立的时候,(这时候其实B++也成立),你不能再算B++,这个地方Wa了n次。居然还有TLE无语。这题花了一上午啊。。
#include<stdio.h>
#include<string.h>
int a[1001],b[1001],c[1001],d[1001];//a[],b[],c[],d[]分别对应第一个人输入的数据(以后要比较的标准),b[]是自己输入的要和第一个人的数据进行比较,c[],d[]就是为了那个特殊的条件而设的,看是否已经计算过来。c[i]标记第一组数据是否算过,d[i]标记第二组数据是否算过。
int count1,count2;//count1计算A的结果,count2计算B的结果
int main()
{
 //freopen("text.txt","r",stdin);
 //freopen("textout.txt","w",stdout);
 int n;
 int count=0;
 while(scanf("%d",&n)!=EOF)//每组数据的个数
 {
  count1=0,count2=0;//清零
  if(n==0)//程序结束的标志
   break;
  int i,j;
 // memset(a,0,sizeof(a));
  //memset(b,0,sizeof(b));
  //memset(c,0,sizeof(c));
 // memset(d,0,sizeof(d));
  for(i=0;i<n;i++)//输入标准的数据
  {
   scanf("%d",&a[i]);//
  }
  printf("Game %d:\n",++count);//指定的格式
  while(1)
  {
   for(i=0;i<n;i++)
   {
    scanf("%d",&b[i]);//待比较的数据
    c[i]=1;//标记初始化为1(当然也可以是0)
    d[i]=1;
   }
   if(b[0]==0)//一组测试数据t结束的标志
    break;
   for(i=0;i<n;i++)
   {
    if(a[i]==b[i])//满足条件1
    {
     count1++;A的计数器+1
     c[i]=0;//标记a[i]已经访问过了
     d[i]=0;//标记b[i]已经访问过了
    }
   }
   for(i=0;i<n;i++)
   {
    if(c[i]!=0)//如果a[i]没有访问过
    {
     for(j=0;j<n;j++)
     {
      if(a[i]==b[j]&&d[j]!=0&&i!=j)//满足条件2
      {
       count2++;
       d[j]=0;//及时标志已经访问过
       break;//加个break居然就A了。。。啊啊呵(原因是一个数只能和一个数匹配),要不然它还会与后面与它相同的数进行比较。。
      }
     }
    }
   }
   printf("    (%d,%d)\n",count1,count2);
   count1=0,count2=0;//计数器清零。。
  }
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值