#POJ2115# C Looooops

30 篇文章 0 订阅
10 篇文章 0 订阅

C Looooops

 

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2  k) modulo 2  k

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2  k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 
Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 
Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0
Sample Output
0
2
32766
FOREVER

题意:

给出数A,B,C,使A不停地累加上C的值,直到A=B为止,求累加的次数,如果不能到达则输出"FOREVER"

注意变量的内存大小有限制,最大可储存2 ^ k,2 ^ k + 1 -> 0

如果有解,则有

A + n * C ≡ B (mod 2 ^ k)

->        n * C ≡ B - A (mod 2 ^ k)

解一个线性同余方程

->  C * x  + (B - A) * y = gcd(C, 2 ^ k)

g = gcd(C , 2 ^ k)

-> C * x / g + (B - A) * y / g = 1

用拓展欧几里得算法求出 x ,此时求出的 x 其实是 x / g,还原后改正负

如果(B - A) % g !=0则方程无解

Code:

Status Accepted
Time 0ms
Memory 164kB
Length 495
Lang C++
Submitted
Shared

#include<iostream>//(C*ans)≡B-A(mod 2^k)
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long LL;
LL A,B,C,k;
void gcd(LL a,LL b,LL &d,LL &x,LL &y){
	if(!b){d=a,x=1LL,y=0LL;}
	else {
		gcd(b,a%b,d,y,x);
		y-=x*(a/b);
	}
	return ;
}
int main(){
	LL d,x,y;
	while(scanf("%lld%lld%lld%lld",&A,&B,&C,&k),A|B|C|k){
		k=(LL)1<<k;
		gcd(C,k,d,x,y);
		if((B-A)%d)printf("FOREVER\n");
		else{
			x*=(B-A)/d;
			k/=d;
			x%=k;
			if(x<0)x+=k;
			printf("%I64d\n",x);
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值