C Looooops poj 2115 扩展欧几里得


C LooooopsTime Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

 statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

根据题目的意思,我们可以写出A+C*x=B(mod 2^k),这个同余式,转换一下可以得到

C*x=B-A(mod 2^k),令a=C,b=B-A,n=2^k,得到a*x=b(mod n),然后再在左边加上

b*y,得到a*x+b*y=b(mod n),这时候我们就可以看出来了,应该使用扩展欧几里得来解,扩展欧几里得解决的是a*x+b*y=gcd(a,b),我们先解出两个特解,a0、b0,然后我们讲a*x+b*y=gcd(a,b)左右两边同时乘上b/gcd(a,b),就可以得到a*x+b*y=b(mod n)这个式子,因此我们将a0×(b/gcd(a,b))%n,就可以得到a*x+b*y=gcd(a,b)的特解,我们知道,扩展欧几里得的通解是x=x0+(b/gcd)*t,为了得到最小解,我们可以让

X=(X%(n/gcd)+n/gcd)%(n/d),这个就是最终的解。


#include<iostream>
#include<stdio.h>
using namespace std;

__int64 EXTENDED_EUCLID(__int64 a,__int64 b,__int64& x,__int64& y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    __int64 d=EXTENDED_EUCLID(b,a%b,x,y);
    __int64 xt=x;
    x=y;
    y=xt-a/b*y;
    return d;
}

int main(void)
{
    __int64 A,B,C,k;
    while(scanf("%I64d %I64d %I64d %I64d",&A,&B,&C,&k))
    {
        if(!A && !B && !C && !k)
            break;

        __int64 a=C;
        __int64 b=B-A;
        __int64 n=(__int64)1<<k;  //2^k
        __int64 x,y;
        __int64 d=EXTENDED_EUCLID(a,n,x,y);

        if(b%d!=0)
            cout<<"FOREVER"<<endl;
        else
        {
            x=(x*(b/d))%n;
            x=(x%(n/d)+n/d)%(n/d);
            printf("%I64d\n",x);
        }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值