Hdu 1051

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14809    Accepted Submission(s): 6069


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
      
      
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
      
      
2 1 3
 

这道题使用贪心算法就可以解决,要注意的是你不可能一开始就把木棍的顺序按照要求排好,你的排序仅仅只是使得原本两个的判断条件变为一个。然后就是对题目的了解,如果木棍之间符合条件,那么可以把它们当成是一根木棍,这样去遍历就可以得到这种规则下的木棍数,即我们想要的结果。

#include<iostream>
#include<cstdio>
#include<memory.h>
#include<algorithm>
using namespace std;
int T;
int N,M;
int b[5010];
struct H{
	int l;
	int w;
};
const int cmp(const H a,const H b){
     if(a.l==b.l) return a.w>b.w;
     return a.l>b.l;
}

int main(){
	while(scanf("%d",&T)!=EOF){
		while(T--){
			int S;
			int n;
			memset(b,0,sizeof(b));
		    H a[5010];
		    scanf("%d",&N);
			for(int i=0;i<N;i++){
				scanf("%d%d",&a[i].l,&a[i].w);
			}

	    sort(a,a+N,cmp);

            S=0;
            n=0;

            while(n<N){
                if(!b[n]){
                M=a[n].w;
                for(int i=n+1;i<N;i++){
                    if(M>=a[i].w&&b[i]==0){
                        M=a[i].w;
                        b[i]=1;
                    }
                }
                S++;
            }
            n++;
            }
            printf("%d\n",S);
          }
	}
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值