Hdu 2122

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1350    Accepted Submission(s): 449


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
  
  
2 1 0 1 10 4 0
 

Sample Output
  
  
10 impossible

       首先要明确使用的是最小生成树的解决方案,其次题目的要求存在无解的情况这里要做一个判断。代码不难,用的是模版

#include<iostream>
#include<cstdio>
#include<algorithm>  
#define inf 9999999
using namespace std;    
int pot[1001];  
int num,ans;
int find(int x)  
{  
    if(pot[x]==x)return x;  
    pot[x]=find(pot[x]);  
    return pot[x];  
}//找到其所在集合的根结点(代表城市)
struct node{  
        int a;
	int b;
	int c;  
}road[10001];//保存道路信息
int cmp(const node a,const node b)  {  
    return a.c<b.c;  
}  
int main()  
{  
    int n,m;  
    while(scanf("%d%d",&n,&m)!=EOF){  
        for(int i=0;i<n;i++)
		pot[i]=i;
		  
        for(int i=0;i<m;i++)  
            scanf("%d%d%d",&road[i].a,&road[i].b,&road[i].c);
			  
        sort(road,road+m,cmp);    
        num=0;//记录到达的数目
        ans=0;//记录路程(必然最短)  
        for(int i=0;i<m;i++)  
        {  
            int x,y;
            x=find(road[i].a);  
            y=find(road[i].b);  
            if(x!=y)  
            {  
                num++;  
                ans+=road[i].c;  
                pot[x]=y;  
            }  
        }  
        if(num<n-1)//判断合法
		printf("impossible\n");  
        else   
                printf("%d\n",ans);
		  
        printf("\n");  
    }  
    return 0;  
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值