[数论]HDOJ 1222 Wolf and Rabbit 欧几里得算法

传送门:Wolf and Rabbit

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4491    Accepted Submission(s): 2253


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
  
  
2 1 2 2 2
 

Sample Output
  
  
NO YES
 

Author
weigang Lee
 

Source
 

解题报告:

题目大意:有一只狼和一只兔子,兔子只能躲在n个洞(编号0~n-1)中的任意一个洞里,狼则每跑m个洞会进洞看看兔子有没有在里面。
              现在给出一个n,m求兔子是否安全。
              例如当n=6,m=2时,狼只能够进去0,2,4三个洞,而兔子只要躲在1,3,5这几个洞里就安全了。


解题思路:利用互质和非互互质的性质。
              对于狼来说,他能进的洞是(m*i)%n,i是奔跑的次数。
              1)n与m互质,(m*i)%n显然可以得到任意的余数,也就是可以进去任意的洞,那么兔子绝对是不安全的。
              2)n与m不互质,(m*i)%n,当i=n/gcd(n,m)时,狼回到了0这个洞又重新开始循环,所以,绝对存在一个洞没有被狼访问过。

所以此题就是GCD,代码如下:

#include<stdio.h>
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int a,b;
        scanf("%d%d",&a,&b);
        if(gcd(a,b)==1)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值