HDU 1085 Holding Bin-Laden Captive!(母函数)

本·拉登提出了一道关于中国硬币的数学难题:给出三种面额的硬币数量,求不能支付的最小金额。本文提供了一个算法解决方案,并通过样例输入输出展示了如何解决这一问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14633    Accepted Submission(s): 6551


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
  
  
1 1 3 0 0 0
 

Sample Output
  
  
4
 

代码

#include<stdio.h>
#include<iostream>
#include<string.h>
#define MAXN 10010
using namespace std;
int main()
{
    int temp[MAXN],ans[MAXN];
    int f[4]={1,2,5};
    int i,m,j,k,n,x[4];
    while(cin >> x[0] >>x[1] >> x[2]&&(x[0]||x[1]||x[2]))
    {
        m=x[0]+2*x[1]+5*x[2];
        memset(ans,0,sizeof(ans));
        memset(temp,0,sizeof(ans));
        for( i=0; i<=x[0]; i+=f[0])
        {
            ans[i]=1;
        }
        for(i=1; i<=2; i++)
        {
            for(j=0; j<=m; j++)
                for(k=0; k<=f[i]*x[i]&&k+j<=m; k+=f[i])
                {
                    temp[k+j] += ans[j] ;
                }
            for(j=0; j<=m; j++)
            {
                ans[j] = temp[j];
                temp[j] = 0;
            }
        }
        for(i=0; i<=m+1; i++)
          if(ans[i] == 0)
            break;
        cout << i <<endl;
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值