HDU 5411 CRB and Puzzle

Problem Description
CRB is now playing Jigsaw Puzzle.
There are  N  kinds of pieces with infinite supply.
He can assemble one piece to the right side of the previously assembled one.
For each kind of pieces, only restricted kinds can be assembled with.
How many different patterns he can assemble with at most  M  pieces? (Two patterns  P  and  Q  are considered different if their lengths are different or there exists an integer  j  such that  j -th piece of  P  is different from corresponding piece of  Q .)
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:
The first line contains two integers  N M  denoting the number of kinds of pieces and the maximum number of moves.
Then  N  lines follow.  i -th line is described as following format.
a1 a2 ... ak
Here  k  is the number of kinds which can be assembled to the right of the  i -th kind. Next  k  integers represent each of them.
1 ≤  T  ≤ 20
1 ≤  N  ≤ 50
1 ≤  M  ≤  105
0 ≤  k  ≤  N
1 ≤  a1  <  a2  < … <  ak  ≤ N

 

Output
For each test case, output a single integer - number of different patterns modulo 2015.
 

Sample Input
  
  
1 3 2 1 2 1 3 0
 

Sample Output
  
  
6
Hint
possible patterns are ∅, 1, 2, 3, 1→2, 2→3

找到递推式,来一发矩阵乘法就ok了

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cstdio>
#include<ctime>
#include<vector>
using namespace std;
const int base = 2015;
const int maxn = 100005;
int T, n, m, k, kk;

struct Matrix
{
    #define size 55
    int m[size][size];
    Matrix() { memset(m, 0, sizeof(m)); }

    void operator =(const Matrix&b) { memcpy(m, b.m, sizeof(m)); }

    Matrix operator *(const Matrix&b) {
        Matrix c;
        for (int i = 0; i < size; i++)
        for (int j = 0; j < size; j++)
        for (int k = 0; k < size; k++)
            c.m[i][k] = (c.m[i][k] + m[i][j] * b.m[j][k]) % base;
        return c;
    }
    Matrix get(int x)
    {
        Matrix a, b = *this;
        for (int f = 0; x; x >>= 1)
        {
            if (x & 1)
            if (f) a = a * b; else a = b, f = 1;
            b = b * b;
        }
        return a;
    }
};

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n, &m);
        Matrix a, b;
        for (int i = 1; i <= n + 1; i++) a.m[i][n + 1] = 1;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &k);
            for (int j = 1; j <= k; j++)
            {
                scanf("%d", &kk);
                a.m[i][kk] = 1;
            }
        }
        for (int i = 1; i <= n + 1; i++) b.m[1][i] = 1;
        a = a.get(m);    
        b = b * a;
        if (m == 1) printf("%d\n", n + 1);
        else printf("%d\n", b.m[1][n + 1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值