HDU 5411(CRB and Puzzle-矩阵A+A^2+..+A^n)

CRB and Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 678    Accepted Submission(s): 253


Problem Description
CRB is now playing Jigsaw Puzzle.
There are N kinds of pieces with infinite supply.
He can assemble one piece to the right side of the previously assembled one.
For each kind of pieces, only restricted kinds can be assembled with.
How many different patterns he can assemble with at most M pieces? (Two patterns P and Q are considered different if their lengths are different or there exists an integer j such that j -th piece of P is different from corresponding piece of Q .)
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:
The first line contains two integers N , M denoting the number of kinds of pieces and the maximum number of moves.
Then N lines follow. i -th line is described as following format.
k a1 a2 ... ak
Here k is the number of kinds which can be assembled to the right of the i -th kind. Next k integers represent each of them.
1 ≤ T ≤ 20
1 ≤ N ≤ 50
1 ≤ M 105
0 ≤ k N
1 ≤ a1 < a2 < … < ak ≤ N

 

Output
For each test case, output a single integer - number of different patterns modulo 2015.
 

Sample Input
  
  
1 3 2 1 2 1 3 0
 

Sample Output
  
  
6
Hint
possible patterns are ∅, 1, 2, 3, 1→2, 2→3
 

Author
KUT(DPRK)
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5426  5425  5424  5423  5422 
 

显然矩阵DP,记得A+A^2+..+A^N 可以用矩阵快速二分优化




#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
#pragma comment(linker, "/STACK:1024000000,1024000000")   
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (2015)
#define eps (1e-3)
#define MAXN (50+10)
typedef __int64 ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}

struct M  
{  
    int n,m;  
    ll a[MAXN][MAXN];  
    M(int _n=0){n=m=_n;MEM(a);}	
    M(int _n,int _m){n=_n,m=_m;MEM(a);}
    void mem (int _n=0){n=m=_n;MEM(a);}
    void mem (int _n,int _m){n=_n,m=_m;MEM(a);}
    
	friend M operator*(M a,M b)  
    {  
        M c;
		c.mem(a.n,b.m) ;
	    For(k,a.m)
		    For(i,a.n)  
	            For(j,b.m)  
	                c.a[i][j]=(c.a[i][j]+a.a[i][k]*b.a[k][j])%F;  
		return c;     
    }  
    friend M operator+(M a,M b)  
    {  
	    For(i,a.n)  
            For(j,a.m)  
                a.a[i][j]=(a.a[i][j]+b.a[i][j])%F;  
		return a;
    }  
    
	void make_I(int _n)  
    {  
    	n=m=_n; MEM(a)
        For(i,n) a[i][i]=1;  
    }  
}f;

M a;
int n,m;

bool a2[1000000];    
M pow2(M a,ll b)  
{  
    M c;c.make_I(a.n);    
    int n=0;while (b) a2[++n]=b&1,b>>=1;    
    For(i,n)    
    {    
        if (a2[i]) c=c*a;    
        a=a*a;    
    }    
    return c;    
}

bool a3[1000000];  
M pow222(M a,ll b)  
{  
    M c;c.make_I(a.n);    
    int n=0;while (b) a3[++n]=b&1,b>>=1;
    c=a; b=1;
    M d=c;
	ForD(i,n-1)    
    {    
		b=b*2+a3[i];
	    c=c*d+c;
	    d=d*d;
	    if (a3[i]) c=c*a+a,d=d*a;
    }    
    return c;    
}


M pow22(M a,ll b)  
{ 
    M c;c.make_I(a.n);    
	if (b==0) return c; 
	if (b==1) return a;
	c=pow22(a,b/2);
	c=c*pow2(a,b/2)+c;
	if (b&1) c=c*a+a;


    return c;    
}


int main()
{
//	freopen("Puzzle.in","r",stdin);
	
	int T; cin>>T;
	while(T--) {
		scanf("%d%d",&n,&m);
		f.mem(n);
		For(i,n) {
			int k;scanf("%d",&k);
			For(j,k) 
			{
				int p;
				scanf("%d",&p);
				f.a[p][i]=1;
			} 
		} 	
		if (m==1)
		{
			cout<<n+1<<endl;
			continue;
		} 
		
//		f.pri();
		f=pow222(f,m-1);
//		f.pri();
		
		ll ans=1+n;
		For(i,n) For(j,n) upd(ans,f.a[i][j]);
		
		printf("%I64d\n",ans);
	} 
	
	
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值