HDU 5615 Jam's math problem

Problem Description

Jam has a math problem. He just learned factorization. He is trying to factorize ax^2+bx+cax2+bx+c into the form of pqx^2+(qk+mp)x+km=(px+k)(qx+m)pqx2+(qk+mp)x+km=(px+k)(qx+m). He could only solve the problem in which p,q,m,k are positive numbers. Please help him determine whether the expression could be factorized with p,q,m,k being postive.

Input

The first line is a number TT, means there are T(1 \leq T \leq 100 )T(1T100) cases

Each case has one line,the line has 33 numbers a,b,c (1 \leq a,b,c \leq 100000000)a,b,c(1a,b,c100000000)

Output

You should output the "YES" or "NO".

Sample Input
2
1 6 5
1 6 4
Sample Output
YES
NO


   
   
Hint
The first case turn x^2+6*x+5x2+6x+5 into (x+1)(x+5) (x+1)(x+5 )
直接上的暴力大法,然而其实只要判断delta是不是平方数就好了
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;

int T, n, m, t1, t2, a, b, c;
struct point
{
    int x, y;
    point(){}
    point(int x, int y) :x(x), y(y){}
}p[maxn], q[maxn];

int main()
{
    scanf("%d", &T);
    while (scanf("%d%d%d", &a, &b, &c) != EOF, T--)
    {
        t1 = t2 = 0;
        for (int i = 1; i*i <= a; i++)
            if (a%i == 0) p[t1++] = point(i, a / i);
        for (int i = 1; i*i <= c; i++)
            if (c%i == 0) q[t2++] = point(i, c / i);
        bool flag = false;
        for (int i = 0; i < t1&&!flag; i++)
        {
            for (int j = 0; j < t2; j++)
            if (p[i].x*q[j].x + p[i].y*q[j].y == b || p[i].y*q[j].x + p[i].x*q[j].y == b)
            {
                flag = true; break;
            }
        }
        if (flag) printf("YES\n"); else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值