POJ 2977 Box walking

Description

You are given a three-dimensional box of integral dimensions lx × ly × lz The edges of the box are axis-aligned, and one corner of the box is located at position (0, 0, 0). Given the coordinates (xyz) of some arbitrary position on the surface of the box, your goal is to return the square of the length of the shortest path along the box’s surface from (0, 0, 0) to (xyz).

If lx = 1, ly = 2, and lz = 1, then the shortest path from (0, 0, 0) to (1, 2, 1) is found by walking from (0, 0, 0) to (1, 1, 0), followed by walking from (1, 1, 0) to (1, 2, 1). The total path length is √8.

Input

The input test file will contain multiple test cases, each of which consists of six integers lxlylzxyz where 1 ≤ lxlylz ≤ 1000. Note that the box may have zero volume, but the point (xyz) is always guaranteed to be on one of the six sides of the box. The end-of-file is marked by a test case with lx = ly = lz = x = y = z = 0 and should not be processed.

Output

For each test case, write a single line with a positive integer indicating the square of the shortest path length. (Note: The square of the path length is always an integer; thus, your answer is exact, not approximate.)

Sample Input

1 1 2 1 1 2
1 1 1 1 1 1
0 0 0 0 0 0

Sample Output

8

5

#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<algorithm>
#include<vector>
#include<cmath>
#include<string>
#include<functional>
using namespace std;
const int maxn=505;
int lx,ly,lz,x,y,z,ans;

int f(int x) {return x*x;}

int main()
{
	while (cin>>lx>>ly>>lz>>x>>y>>z,x+y+z+lx+ly+lz)
	{
		ans=0x7FFFFFFF;
		if (x==0||y==0||z==0) ans=f(x)+f(y)+f(z);
		else 
		if (x==lx) 
		{
			ans=min(ans,min(f(x+y)+f(z),f(x+z)+f(y)));
			ans=min(ans,min(f(y+lz)+f(lx+lz-z),f(z+ly)+f(lx+ly-y)));
		}
		else 
		if (y==ly) 
		{
			ans=min(ans,min(f(y+x)+f(z),f(y+z)+f(x)));
			ans=min(ans,min(f(x+lz)+f(ly+lz-z),f(z+lx)+f(ly+lx-x)));
		}
		else
		if (z==lz)
		{
			ans=min(ans,min(f(z+y)+f(x),f(z+x)+f(y)));
			ans=min(ans,min(f(y+lx)+f(lx+lz-x),f(x+ly)+f(ly+lz-y)));
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值