PAT (Advanced Level) Practise 1081 Rational Sum (20)

1081. Rational Sum (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:

7/24

分数加减,注意判断特殊情况。

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
LL n, x, y, z, a, b, c;
char s[maxn];

LL gcd(LL x, LL y)
{
	if (!x || !y) return x | y;
	return x%y ? gcd(y, x%y) : y;
}

void add()
{
	if (c == 0) { a = x, b = y, c = z; return; }
	LL g = gcd(c, z);
	LL gg = c / g * z;
	b = z / g * b;
	y = c / g * y;
	if (a == x) b += y;
	else if (a == 0)
	{
		if (b >= y) b -= y; else a = 1, b = y - b;
	}
	else
	{
		if (b > y) b -= y; else a = 0, b = y - b;
	}
	g = gcd(gg, b);
	b /= g;	c = gg / g;
}

int main()
{
	scanf("%lld", &n);
	while (n--)
	{
		scanf("%s", s);
		x = s[0] == '-';
		sscanf(s + x, "%lld/%lld", &y, &z);
		LL g = gcd(y, z);
		y /= g;	z /= g;
		add();
	}
	if (a) printf("-");
	if (b / c) printf("%lld", b / c);
	if (b / c && b%c) printf(" ");
	if (b % c) printf("%lld/%lld", b%c, c);
	if (!(b / c) && !(b%c)) printf("0");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值