【PAT】1081. Rational Sum (20)

题目描述

Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

翻译:以“分子/分母”的格式给你N个有理数,你需要计算他们的和。

INPUT FORMAT

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

翻译:每个输入文件包含一组测试数据。每组测试数据开始为一个正整数N(<=100),接着N行有理数”a1/b1 a2/b2 …” ,所有的分子分母都在长整数范围内。如果有负数,那么符号一定在分子前面。

OUTPUT FORMAT

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

翻译:对于每组输入数据,输出“整数 分子/分母”的最简格式,“整数“为和的整数部分,“分子”小于“分母”,并且分子和分母之间没有公约数。如果整数部分为0你只需输出小数部分。


Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3


Sample Input 2:

2
4/3 2/3

Sample Output 2:

2


Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24


解题思路

通过求最小公倍数解决,注意每次求和完分子后都需要将假分数化为最简。当且仅当整数为0时只输出分数,当且仅当分数为0时输出整数部分,当全为0时注意要输出0。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
long long int N;
long long int gcd(long long int a,long long int b){
    return b?gcd(b,a%b):a;
}
int main(){
    scanf("%lld",&N);
    long long int a,b;
    long long int numerator=1,denominator=1,sum=0;
    for(int i=0;i<N;i++){
        scanf("%lld/%lld",&a,&b);
        long long int temp=gcd(b,denominator);
        sum=b/temp*sum+denominator/temp*a;
        denominator=b/temp*denominator;
        temp=gcd(sum,denominator);
        sum=sum/temp;
        denominator=denominator/temp;
    }
    numerator=sum/denominator;
    long long int pre=sum%denominator;

    if(numerator)printf("%lld",numerator);
    if(numerator&&pre)printf(" ");
    if(pre)printf("%lld/%lld",pre,denominator);
    if(!numerator&&!pre)printf("0");
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值