【PAT】1081. Rational Sum (20)

题目描述

Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

翻译:以“分子/分母”的格式给你N个有理数,你需要计算他们的和。

INPUT FORMAT

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

翻译:每个输入文件包含一组测试数据。每组测试数据开始为一个正整数N(<=100),接着N行有理数”a1/b1 a2/b2 …” ,所有的分子分母都在长整数范围内。如果有负数,那么符号一定在分子前面。

OUTPUT FORMAT

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

翻译:对于每组输入数据,输出“整数 分子/分母”的最简格式,“整数“为和的整数部分,“分子”小于“分母”,并且分子和分母之间没有公约数。如果整数部分为0你只需输出小数部分。


Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3


Sample Input 2:

2
4/3 2/3

Sample Output 2:

2


Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24


解题思路

通过求最小公倍数解决,注意每次求和完分子后都需要将假分数化为最简。当且仅当整数为0时只输出分数,当且仅当分数为0时输出整数部分,当全为0时注意要输出0。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
long long int N;
long long int gcd(long long int a,long long int b){
    return b?gcd(b,a%b):a;
}
int main(){
    scanf("%lld",&N);
    long long int a,b;
    long long int numerator=1,denominator=1,sum=0;
    for(int i=0;i<N;i++){
        scanf("%lld/%lld",&a,&b);
        long long int temp=gcd(b,denominator);
        sum=b/temp*sum+denominator/temp*a;
        denominator=b/temp*denominator;
        temp=gcd(sum,denominator);
        sum=sum/temp;
        denominator=denominator/temp;
    }
    numerator=sum/denominator;
    long long int pre=sum%denominator;

    if(numerator)printf("%lld",numerator);
    if(numerator&&pre)printf(" ");
    if(pre)printf("%lld/%lld",pre,denominator);
    if(!numerator&&!pre)printf("0");
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值