1081. Rational Sum (20)

1081. Rational Sum (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
N个分数

求这些分数的和,并且最后的形势是真分数形式;比如  6/3 =2; 4/8=1/2;10/3=3 1/3;
输入的可能是假分数形式,先把假分数的处理成真分数在进行加减,否则会超时;
用到辗转相除法求最大公约数   被除数÷除数=商……余数;
                                      如果余数是0,那么此时的被除数是最大公约数;
                                             否则 被除数=除数;除数=余数,继续
int gcd(int b1, int b2)
{ 
    return b2==0 ? b1 : gcd(b2, b1%b2);
}

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月17日 14:32答案正确201081C++ (g++ 4.7.2)1436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确14364/4
1答案正确14364/4
2答案正确11804/4
3答案正确13844/4
4答案正确13084/4

#include<iostream>   
using namespace std;   
int gcd(int b1, int b2)
{ 
    return b2==0 ? b1 : gcd(b2, b1%b2);
}
int main()
{
  int N;
  long int a1, a2, b1, b2,Gmax;
  char ctemp;
  cin >> N ;
  a1 = 0;
  b1 = 1;
  while (N--)
  {
    cin >> a2 >> ctemp >> b2;  
    Gmax =gcd(b2, a2);
    b2 /= Gmax;
    a2 /= Gmax;
    Gmax = gcd(b1, b2);
    b2 /= Gmax;
    a1 = a1*b2+a2*b1/Gmax;
    b1 = b1*b2; 
  }   
  if(a1%b1 == 0)cout << a1 / b1 << endl;
  else
  {
      Gmax = gcd(b1, a1);
    b1 /= Gmax;
    a1 /= Gmax;
    if (0 == a1 / b1)
    {
      cout << a1 << "/" << b1 << endl;
    }
    else
    {
      cout << a1 / b1 << " " << a1%b1 << "/" << b1 << endl;
    }
  }
    system("pause");
  return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值