POJ 3259 Wormholes 最短路径 Bellman_Ford

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16566 Accepted: 5834

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

 

题意:

FJ要去N个农场旅行 有M个路径 和 W个虫洞,虫洞可以回到过去;

问 FJ在旅行是 能否看见 过去的 自己; 

注意 路径是双向的 ,虫洞是单向的;

思路:

bellman算法 判断 是否存在负权回路

以为 是 回到源点的时间<1就行了,贡献两个WA; 

#include <iostream>
using namespace std; 
int dis[501];
int n,m,w;
struct Edge
{
	int s,e,t;
}e[5210];
bool BellMan_Ford()
{
	int i,j;
	memset(dis, 10001, sizeof(dis));
	dis[1] = 1;
	for(i=1; i<n; i++)
	{
		bool flag = true;
		for(j=1; j<=2*m+w; j++)
		{
			if(dis[e[j].e] > (dis[e[j].s]+e[j].t))
			{
				dis[e[j].e] = dis[e[j].s]+e[j].t;
				flag = false;
			}
		}
		if(flag) break;
	}
	for(j=1; j<=2*m+w; j++)
	if(dis[e[j].e] > (dis[e[j].s]+e[j].t))
	{
		return true;
	}
	return false;
}
int main()
{
	int t,i;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d %d %d", &n, &m, &w);
		for(i=1; i<=m; i++)
		{
			scanf("%d %d %d", &e[i].s, &e[i].e, &e[i].t);
			e[i+m].s = e[i].e; e[i+m].e = e[i].s; e[i+m].t = e[i].t;
		}
		for(i=2*m+1; i<=2*m+w; i++)
		{
			scanf("%d %d %d", &e[i].s, &e[i].e, &e[i].t);
			e[i].t = -e[i].t;
		}
		if(BellMan_Ford()) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值