字符串B Where's Waldorf?

10010 Where’s Waldorf?Given a m by n grid of letters, (1 ≤ m, n ≤ 50), and a list of words, find the location in the grid atwhich the word can be found.A word matches a straight, uninterrupted line of letters in the grid. A word can match the lettersin the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). Thematching can be done in any of the eight directions either horizontally, vertically or diagonally throughthe grid.InputThe input begins with a single positive integer on a line by itself indicating the numberof the cases following, each of them as described below. This line is followed by a blankline, and there is also a blank line between two consecutive inputs.The input begins with a pair of integers, m followed by n, 1 ≤ m, n ≤ 50 in decimal notation on asingle line. The next m lines contain n letters each; this is the grid of letters in which the words of thelist must be found. The letters in the grid may be in upper or lower case. Following the grid of letters,another integer k appears on a line by itself (1 ≤ k ≤ 20). The next k lines of input contain the list ofwords to search for, one word per line. These words may contain upper and lower case letters only (nospaces, hyphens or other non-alphabetic characters).OutputFor each test case, the output must follow the description below. The outputs of twoconsecutive cases will be separated by a blank line.For each word in the word list, a pair of integers representing the location of the correspondingword in the grid must be output. The integers must be separated by a single space. The first integeris the line in the grid where the first letter of the given word can be found (1 represents the topmostline in the grid, and m represents the bottommost line). The second integer is the column in the gridwhere the first letter of the given word can be found (1 represents the leftmost column in the grid, andn represents the rightmost column in the grid). If a word can be found more than once in the grid,then the location which is output should correspond to the uppermost occurence of the word (i.e. theoccurence which places the first letter of the word closest to the top of the grid). If two or more wordsare uppermost, the output should correspond to the leftmost of these occurences. All words can befound at least once in the grid.Sample Input18 11abcDEFGhigghEbkWalDorkFtyAwaldORmFtsimrLqsrcbyoArBeDeyvKlcbqwikomkstrEBGadhrbUniversidad de Valladolid OJ: 10010 – Where’s Waldorf? 2/2yUiqlxcnBjf4WaldorfBambiBettyDagbertSample Output2 52 31 27 8


#include<cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
using namespace std;
char s[100][100];
char x[100];
int is_find(int m,int n,int i,int j)
{
  int k,p,h,l,flag,len=strlen(x);
  if(i+1>=len){
    p=0;flag=1;
    for(k=i;k>=i+1-len;k--)
      if(s[k][j]!=x[p++])
      {flag=0;break;}
    if(flag)
      return 1;
  }
  if(m-i>=len){
    p=0;flag=1;
    for(k=i;k<i+len;k++)
      if(s[k][j]!=x[p++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(j+1>=len){
    p=0;flag=1;
    for(k=j;k>=j+1-len;k--)
      if(s[i][k]!=x[p++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(n-j>=len){
    p=0;flag=1;
    for(k=j;k<j+len;k++)
      if(s[i][k]!=x[p++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(i+len<=m&&j+len<=n){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h++][l++])
        {flag=0;break;}
      if(flag)
      return 1;


  }
  if(i+1>=len&&j+1>=len){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h--][l--])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(i+1>=len&&j+len<=n){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h--][l++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(i+len<=m&&j+1>=len){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h++][l--])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  return 0;
}
int main()
{
  int T,i,j,m,n,k,p;
  scanf("%d",&T);
  while(T--){
    scanf("%d %d",&m,&n);
    for(i=0;i<m;i++)
    scanf("%s",s[i]);
    for(i=0;i<m;i++)
      for(j=0;j<n;j++)
      s[i][j]=toupper(s[i][j]);
    scanf("%d",&k);
    while(k--){
        scanf("%s",x);p=0;
        for(i=0;i<strlen(x);i++)
        x[i]=toupper(x[i]);
       for(i=0;i<m;i++){
        for(j=0;j<n;j++)
        if(is_find(m,n,i,j)){
            printf("%d %d\n",i+1,j+1);
            p=1;
            break;
            }
            if(p)
          break;
      }
      }
      if(T)
    printf("\n");
  }
  return 0;
}

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值