字符串B Where's Waldorf?

10010 Where’s Waldorf?Given a m by n grid of letters, (1 ≤ m, n ≤ 50), and a list of words, find the location in the grid atwhich the word can be found.A word matches a straight, uninterrupted line of letters in the grid. A word can match the lettersin the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). Thematching can be done in any of the eight directions either horizontally, vertically or diagonally throughthe grid.InputThe input begins with a single positive integer on a line by itself indicating the numberof the cases following, each of them as described below. This line is followed by a blankline, and there is also a blank line between two consecutive inputs.The input begins with a pair of integers, m followed by n, 1 ≤ m, n ≤ 50 in decimal notation on asingle line. The next m lines contain n letters each; this is the grid of letters in which the words of thelist must be found. The letters in the grid may be in upper or lower case. Following the grid of letters,another integer k appears on a line by itself (1 ≤ k ≤ 20). The next k lines of input contain the list ofwords to search for, one word per line. These words may contain upper and lower case letters only (nospaces, hyphens or other non-alphabetic characters).OutputFor each test case, the output must follow the description below. The outputs of twoconsecutive cases will be separated by a blank line.For each word in the word list, a pair of integers representing the location of the correspondingword in the grid must be output. The integers must be separated by a single space. The first integeris the line in the grid where the first letter of the given word can be found (1 represents the topmostline in the grid, and m represents the bottommost line). The second integer is the column in the gridwhere the first letter of the given word can be found (1 represents the leftmost column in the grid, andn represents the rightmost column in the grid). If a word can be found more than once in the grid,then the location which is output should correspond to the uppermost occurence of the word (i.e. theoccurence which places the first letter of the word closest to the top of the grid). If two or more wordsare uppermost, the output should correspond to the leftmost of these occurences. All words can befound at least once in the grid.Sample Input18 11abcDEFGhigghEbkWalDorkFtyAwaldORmFtsimrLqsrcbyoArBeDeyvKlcbqwikomkstrEBGadhrbUniversidad de Valladolid OJ: 10010 – Where’s Waldorf? 2/2yUiqlxcnBjf4WaldorfBambiBettyDagbertSample Output2 52 31 27 8


#include<cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
using namespace std;
char s[100][100];
char x[100];
int is_find(int m,int n,int i,int j)
{
  int k,p,h,l,flag,len=strlen(x);
  if(i+1>=len){
    p=0;flag=1;
    for(k=i;k>=i+1-len;k--)
      if(s[k][j]!=x[p++])
      {flag=0;break;}
    if(flag)
      return 1;
  }
  if(m-i>=len){
    p=0;flag=1;
    for(k=i;k<i+len;k++)
      if(s[k][j]!=x[p++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(j+1>=len){
    p=0;flag=1;
    for(k=j;k>=j+1-len;k--)
      if(s[i][k]!=x[p++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(n-j>=len){
    p=0;flag=1;
    for(k=j;k<j+len;k++)
      if(s[i][k]!=x[p++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(i+len<=m&&j+len<=n){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h++][l++])
        {flag=0;break;}
      if(flag)
      return 1;


  }
  if(i+1>=len&&j+1>=len){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h--][l--])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(i+1>=len&&j+len<=n){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h--][l++])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  if(i+len<=m&&j+1>=len){
    h=i;l=j;flag=1;
    for(k=0;k<len;k++)
      if(x[k]!=s[h++][l--])
      {flag=0;break;}
    if(flag)
    return 1;
  }
  return 0;
}
int main()
{
  int T,i,j,m,n,k,p;
  scanf("%d",&T);
  while(T--){
    scanf("%d %d",&m,&n);
    for(i=0;i<m;i++)
    scanf("%s",s[i]);
    for(i=0;i<m;i++)
      for(j=0;j<n;j++)
      s[i][j]=toupper(s[i][j]);
    scanf("%d",&k);
    while(k--){
        scanf("%s",x);p=0;
        for(i=0;i<strlen(x);i++)
        x[i]=toupper(x[i]);
       for(i=0;i<m;i++){
        for(j=0;j<n;j++)
        if(is_find(m,n,i,j)){
            printf("%d %d\n",i+1,j+1);
            p=1;
            break;
            }
            if(p)
          break;
      }
      }
      if(T)
    printf("\n");
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值