The Settlers of Catan
The Settlers of Catan |
Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:
When the game ends, the player who built the longest road gains two extra victory points.
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.
Example: The following network contains a road of length 12.
o o -- o o \ / \ / o -- o o -- o / \ / \ o o -- o o -- o \ / o -- o
Input
The input file will contain one or more test cases.The first line of each test case contains two integers: the number of nodes n ( ) and the number of edges m (). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.
Input will be terminated by two values of 0 for n and m.
Output
For each test case, print the length of the longest road on a single line.
Sample Input
3 2 0 1 1 2 15 16 0 2 1 2 2 3 3 4 3 5 4 6 5 7 6 8 7 8 7 9 8 10 9 11 10 12 11 12 10 13 12 14 0 0
Sample Output
2 12题目大意:给出一个连接图,求最长不重复路径,输出值。
解题思路:用二维数组存放两点间连接情况,深度收索查找最长路径。
#include<stdio.h>
#include<string.h>
#define N 26
int map[N][N];
int tem[N][N];
int max;
int n;
void find(int h,int time)
{
int i;
for(i = 0;i < n; i++)
{
if(map[h][i]&&!tem[h][i])
{
tem[h][i]=tem[i][h]=1;
find(i,time+1);
tem[h][i]=tem[i][h]=0;
}
}
if(time > max)
max = time;
}
int main()
{
int m;
while(scanf("%d%d",&n,&m),n&&m)
{
//Init.
memset(map,0,sizeof(map));
memset(tem,0,sizeof(tem));
max=0;
//Read.
for(int i = 0;i < m; i++)
{
int a,b;
scanf("%d%d",&a,&b);
map[a][b]=map[b][a]=1;
}
//Count.
for(int i = 0;i < n; i++)
for(int j = 0;j < n ; j++)
if(map[i][j])
{
tem[i][j]=tem[j][i]=1;
find(j,1);
tem[i][j]=tem[j][i]=0;
}
//Cout.
printf("%d\n",max);
}
return 0;
}