uva 539 The Settlers of Catan

737 篇文章 0 订阅
223 篇文章 1 订阅

  The Settlers of Catan 

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o

Input 

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( $2 \le n \le 25$) and the number of edges m ($1 \le m \le 25$). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output 

For each test case, print the length of the longest road on a single line.

Sample Input 

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output 

2
12
题目大意:给出一个连接图,求最长不重复路径,输出值。

解题思路:用二维数组存放两点间连接情况,深度收索查找最长路径。

#include<stdio.h>
#include<string.h>

#define N 26

int map[N][N];
int tem[N][N];
int max;
int n;

void find(int h,int time)
{
	int i;

	for(i = 0;i < n; i++)
	{
		if(map[h][i]&&!tem[h][i])
		{
			tem[h][i]=tem[i][h]=1;
			find(i,time+1);
			tem[h][i]=tem[i][h]=0;
		}
	}

	if(time > max)
		max = time;
}

int main()
{
	int m;

	while(scanf("%d%d",&n,&m),n&&m)
	{
		//Init.
		memset(map,0,sizeof(map));
		memset(tem,0,sizeof(tem));
		max=0;

		//Read.
		for(int i = 0;i < m; i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			map[a][b]=map[b][a]=1;
		}

		//Count.
		for(int i = 0;i < n; i++)
			for(int j = 0;j < n ; j++)
				if(map[i][j])
				{
					tem[i][j]=tem[j][i]=1;
					find(j,1);
					tem[i][j]=tem[j][i]=0;
				}
		//Cout.
		printf("%d\n",max);
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值