uva 10422 Knights in FEN(迭代dfs)

737 篇文章 0 订阅
223 篇文章 1 订阅

Knights in FEN

Input: standard input

Output: standard output

Time Limit: 10 seconds

 

There are black and white knights on a 5 by 5 chessboard. There are twelve of each color, and there is one square that is empty. At any time, a knight can move into an empty square as long as it moves like a knight in normal chess (what else did you expect?).

Given an initial position of the board, the question is: what is the minimum number of moves in which we can reach the final position which is:

Input

First line of the input file contains an integer N (N<14) that indicates how many sets of inputs are there. The description of each set is given below:

Each set consists of five lines; each line represents one row of a chessboard. The positions occupied by white knights are marked by 0 and the positions occupied by black knights are marked by 1. The space corresponds to the empty square on board.

There is no blank line between the two sets of input.

The first set of the sample input below corresponds to this configuration:

Output

For each set your task is to find the minimum number of moves leading from the starting input configuration to the final one. If that number is bigger than 10, then output one line stating

Unsolvable in less than 11 move(s).

 

otherwise output one line stating

Solvable in n move(s).

where n <= 10.

The output for each set is produced in a single line as shown in the sample output.

Sample Input

2
01011
110 1
01110
01010
00100
10110
01 11
10111
01001
00000

Sample Output

Unsolvable in less than 11 move(s).
Solvable in 7 move(s).

题目大意:初始状态唯一(空格处于中间,题目有给出), 给出一个状态,问在7个移动以内可否到达。

解题思路:每次确定dfs的深度,将所有可能收索一遍。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const char begin[5][5] = {'1', '1', '1', '1', '1', '0', '1', '1', '1', '1', '0', '0', ' ', '1', '1', '0', '0', '0', '0', '1', '0', '0', '0', '0', '0'};
const int dx[] = {-2, -2, 2, 2, -1, 1, -1, 1};
const int dy[] = {-1, 1, -1, 1, -2, -2, 2, 2};

char r[5][5];
int ans;
bool flag;

int diff() {
    int sum = 0;
    for (int i = 0; i < 5; i++)
	for (int j = 0; j < 5; j++)
	    sum += (r[i][j] != begin[i][j]);
    return sum / 2;
}

void dfs(int deep, int x, int y) {
    if (deep >= ans) {
	if (memcmp(r, begin, 25 * sizeof(char)) == 0)
	    flag = true;
	return;
    }
    if (deep + diff() > ans)
	return ;
    int swap;
    for (int i = 0; i < 8 && !flag; i++) {
	int newX = x + dx[i], newY = y + dy[i];
	if (newX < 0 || newX >= 5 || newY < 0 || newY >= 5)
	    continue;

	swap = r[x][y];
	r[x][y] = r[newX][newY];
	r[newX][newY] = swap; 

	dfs(deep + 1, newX, newY);

	swap = r[x][y];
	r[x][y] = r[newX][newY];
	r[newX][newY] = swap; 
    }
}

int main() {
    int cas;
    scanf("%d%*c", &cas);
    while (cas--) {
	int x, y;
	for (int i = 0; i < 5; i++) {
	    for (int j = 0; j < 5; j++) {
		scanf("%c", &r[i][j]);
		if (r[i][j] == ' ') {
		    x = i;
		    y = j;
		}
	    }
	    getchar();
	}

	flag = 0;
	for (ans = 0; ans <= 10; ans++) {
	    dfs(0, x, y);
	    if (flag)
		break;
	}

	if (flag)
	    printf("Solvable in %d move(s).\n", ans);
	else
	    printf("Unsolvable in less than 11 move(s).\n");
    }
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值