fjnu 1836 Humble Numbers

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

 

KEY:这题肯定不能用模拟的,这题很巧的,我看了USACO的标程算法才做出来的;如果前 m-1 个丑数已经求出来了(包含 0),那么第 m 个数肯定是由前面某个丑数乘 S 里的素数得来的。假设是 h[pindex[i]] p[i] 而得到 h[m] 的话,把每次乘 p[i] pindex[i] 列出来;

#include < iostream >
#define  MAX 2000000001
using   namespace  std;

int  prime[] = {0,2,3,5,7} ;
int  pos[ 6 ] = {0,1,1,1,1} ;
int  hum[ 6000 ] = {0,1,0} ;
int  num = 2 ;

void  GetList()
{
    
int min;
    
int i;
    
while(num<=5842)
    
{
        min
=MAX;
        
for(i=1;i<=4;i++)
        
{
            
while(hum[pos[i]]*prime[i]<=hum[num-1]) pos[i]++;
            
if(hum[pos[i]]*prime[i]<min) 
            
{
                 min
=hum[pos[i]]*prime[i];
            }

        }

        hum[num
++]=min;
    }

}


int  main()
{
//    freopen("fjnu_1836.in","r",stdin);
    GetList();
    
int n;
    
while(cin>>n&&n!=0)
    
{
        cout
<<"The "<<n;
        
if(n%100>=10&&n%100<=20) cout<<"th";
        
else 
        
{
            
if(n%10==1) cout<<"st";
            
if(n%10==2) cout<<"nd";
            
if(n%10==3) cout<<"rd";
            
if(n%10>=4||n%10==0) cout<<"th";
        }

        cout
<<" humble number is "<<hum[n]<<"."<<endl;
    }

    
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值