hdu2639 bone collector II 01背包第k优解 TWT Tokyo Olympic 1COMBO-1

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4222 Accepted Submission(s): 2200


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1

Sample Output
  
  
12 2 0

Author
teddy

Source

 
哈哈哈哈哈

终于A了这题

题意就是把bone collector改造一下啊,不要输出最优解,要输出第k解

那么每个状态表示的意义就是拿到第 i 个物品时,用 j 的容量能装下的前 k 优个解,网上的题解讲的很好,f [ i ] [ j ]实际上就是f [ i - 1] [ j ]和f [ i - 1 ] [ j - v [ i ] ] + value [ i ]这两个有序数列的合并!

就要开个三维数组啦

机房空调好冷啊。。。腿都吹麻了。。。

这个网上的题解都是一维的01背包啊,但是我比较习惯写二维的啊。。

问了想飞菜鸡,他就说套模板。。。干、、、、

然后自己写写写,总是调不出结果,实在不明白为啥。。。

然后发现是f [ i - 1] [ j ]和f [ i - 1 ] [ j - v [ i ] ] + value [ i ]这两个有序数列合并时要去重。。。。

然后就过了。。

#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>
int value[110],v[110];
int f[110][1010][35];
int killme[1010];
using namespace std;
bool compare(int a,int b){
    return a>b;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n,V,k,i,j,count;
        scanf("%d%d%d",&n,&V,&k);
        for(i=1;i<=n;i++){
            scanf("%d",&value[i]);     
        }
        for(i=1;i<=n;i++){
            scanf("%d",&v[i]);                  
        }
        memset(f,0,sizeof(f));
        for(i=1;i<=n;i++){
            for(j=0;j<=V;j++){
                int now=1;
                if(j>=v[i]){
                    for(count=1;count<=k;count++){
                        killme[now]=f[i-1][j-v[i]][count]+value[i];
                        now++;
                        killme[now]=f[i-1][j][count];
                        now++;
                    }
                    sort(killme+1,killme+now,compare);
                    int baby=1;
                    for(count=1;baby<=k;count++){
                        if(count==1){
                            f[i][j][baby]=killme[count];
                            baby++;
                            continue;
                        }else{
                            while(killme[count]==killme[count-1]&&killme[count]!=0){
                                count++;
                            }
                            if(killme[count]==0){
                                break;
                            }
                        }
                        f[i][j][baby]=killme[count];
                        baby++;                             
                    }
                    if(killme[count]==0&&baby<=k){
                        for(count=baby;count<=k;count++){
                            f[i][j][count]=0;
                        }
                    }
                }else{
                    for(count=1;count<=k;count++){
                        f[i][j][count]=f[i-1][j][count];
                    }
                }
                /*cout<<"i: "<<i<<" j: "<<j<<endl;
                for(count=1;count<=k;count++){
                    cout<<f[i][j][count]<<" ";
                }
                cout<<endl;*/
            }      
        }
        
        cout<<f[n][V][k]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值