HDU 2639 Bone Collector II 01背包第k优解

题目描述:

Description
The title of this problem is familiar,isn’t it?yeah,if you had took part in the “Rookie Cup” competition,you must have seem this title.If you haven’t seen it before,it doesn’t matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1 

Sample Output

12
2
0 

题目分析:

Bone Collector I 是一个最简单最标准的01背包问题,现在在这个问题上,提出一个新问题,就是求解第k优解,而不是最优解。
(我在先前的博客有谈到最简单01背包问题)
用A B两个数组记录每一次判断是否加入背包的过程,A数组记录加入的,B数组记录不加入的,然后合并这两个数组,得出其中第K优解。

代码如下:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>


using namespace std;

int T;
int n,v,k;
int dp[1010][33];//dp[j][k]表示占用体积j的情况下第k优的值
int val[1010];
int vol[1010];
int A[33];
int B[33];//A B 两记录数组

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&v,&k);
        for(int i=1; i<=n; i++)
            scanf("%d",&val[i]);
        for(int i=1; i<=n; i++)
            scanf("%d",&vol[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            for(int j=v; j>=vol[i]; j--)
            {
                for(int kk=1; kk<=k; kk++)
                {
                    A[kk]=dp[j-vol[i]][kk]+val[i];
                    B[kk]=dp[j][kk];
                }
                int a=1,b=1,c=1;//累加器 
                A[k+1]=B[k+1]=-1;
                while(c<=k && (a<=k || b<=k))
                {
                    if (A[a]>B[b])
                    {
                        dp[j][c]=A[a++];
                    }
                    else
                    {
                        dp[j][c]=B[b++];
                    }
                    if (dp[j][c]!=dp[j][c-1]) c++;
                }
            }
        }
        printf("%d\n",dp[v][k]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值