ZOJ 3609 Modular Inverse (FLOYD判圈算法)

Modular Inverse

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8
 
题意:给出一个a和m,要求找到一个整数x满足:ax≡1 (mod m)。
思路:将算式化简一下,得到x=(k*m+1)/a ,要求x是整数,即判断有没有存在k使得x为整数,如果不存在的话,怎么证明不存在,这里就用到了FLOY判圈算法。
这个算法简单的讲,就是要判断一个链表是否有环,只需要设置两个指针在同一个起点,一个指针每次向前走一步,另一个每次向前走两步,如果成环的话,两个指针会再次相遇。
这里就用到这个原理,刚开始将k值都设置成1,然后p的值是每次加一个m后取模,q的值是每次加两个m后取模,看个值能否再次相等且不为0,如果相等且不为0,则有循环,即不存在。
<strong><span style="font-size:24px;">#include<iostream>
using namespace std;
int main()
{
    int cases,i,a,m,p,q;
    cin>>cases;
    while(cases--)
    {
        cin>>a>>m;
        if(a==1)//特殊情况处理,a=1时,x为1即可
        {
            cout<<1<<endl;
            continue;
        }
        p=(m+1)%a;q=p;//p和q两个指针的起点设置成相同
        for(i=1;;i++)
        {
            if(i!=1)//i不等于1时开始走
            {
            p=(p+m)%a;//p每次前进一步,即加一个m
            q=(q+2*m)%a;//q每次前进两步,即加两个m
            }
            if(p==0){cout<<(i*m+1)/a<<endl;break;}//如果找到一个一个数能够被a整除,就停下来输出
            if(p==q&&p!=0&&i!=1)//如果在起点之后两个指针对应的数相同,且不为0,说明已经走到原位,循环存在
            {
                cout<<"Not Exist"<<endl;
                break;
            }
        }
    }
    return 0;
}
</span></strong>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值