浙江省第十四次ACM程序竞赛 Let's Chat(D题)

Let's Chat

Time Limit: 1 Second      Memory Limit: 65536 KB

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last m consecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ mn), x and y (1 ≤ x, y ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers la, i and ra, i (1 ≤ la, ira, in), indicating that A sent messages to B on each day between the la, i-th day and the ra, i-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lb, i and rb, i (1 ≤ lb, irb, in), indicating that B sent messages to A on each day between the lb, i-th day and the rb, i-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

Sample Input
2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5
Sample Output
3
0

题意:A、B两人互发消息,若连续互发m天,这友谊指数+1,求最终的友谊指数,如n=5,m=3,两人在1-4天都互发消息,则友谊为2,即 1 2 3 ,2 3 4 两个连续的三天。

分析:找到他们的交集,然后判断即可。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100+10;
struct node{
	int l,r;
}X[maxn],Y[maxn];
int n,m,x,y;

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d%d%d",&n,&m,&x,&y);
		for(int i=1;i<=x;i++)
		scanf("%d%d",&X[i].l,&X[i].r);
		for(int i=1;i<=y;i++)
		scanf("%d%d",&Y[i].l,&Y[i].r);
		
		int tol=0;
		for(int i=1;i<=x;i++)
		{
			if(X[i].r-X[i].l+1 < m)continue;  //小于m就不用进行下面操作了 
			
			for(int j=1;j<=y;j++)
			{
				if(Y[j].r-Y[j].l+1 < m)continue;
				
				int L,R;
				R=min(X[i].r,Y[j].r);
				L=max(X[i].l,Y[j].l);
				int len=R-L+1;
				if(len>=m){
					tol+=(len-m+1);
				}
			}
		}
		printf("%d\n",tol);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值