D - Let's Chat

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last mconsecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ xy ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers lai and rai (1 ≤ la,i ≤ rai ≤ n), indicating that A sent messages to B on each day between the lai-th day and the rai-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lbi and rbi (1 ≤ lb,i ≤ rbi ≤ n), indicating that B sent messages to A on each day between the lbi-th day and the rbi-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < xrai + 1 < lai + 1 and for all 1 ≤ i < yrbi + 1 < lbi + 1.

<h4< dd="">Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

<h4< dd="">Sample Input
2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5
<h4< dd="">Sample Output
3
0
<h4< dd="">Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.



思路:

刚开始的时候想的太暴力了,结果果然超时,后来在想想觉得应该是有关集合之间的运算的,因为x,y的给出的集合没有说不会有重复,所以我先对他们给出的集合进行了合并,在对这两个集合进行并的操作,得出所有的交集在求解,这里一定要注意的是一定要先求x,y的并集,不能直接就求他们两个人的交集,不然可能导致求出来的并集有重复


#include <iostream>
#include <cstdio>
#include <set>
#include <vector>
#include <algorithm>
#include <cstdlib>
using namespace std;
struct node {
int st,ed;
int fou;
}th[220], th2[220], ch[220],ch2[220],ans[220];
int main()
{
    int num;
    scanf("%d", &num);
    int n,m,x,y;
    while(num --){
        scanf("%d %d %d %d", &n, &m, &x, &y);
        for(int i = 0; i < x; i ++){
            scanf("%d %d", &th[i].st, &th[i].ed);
            th[i].fou = false;
        }
        for(int i = 0; i < y; i ++){
            scanf("%d %d", &ch[i].st, &ch[i].ed);
            ch[i].fou = false;
        }
        int k = 0, k2 = 0;
       for(int i = 0; i < x; i ++){
            if(th[i].fou) continue;
        for(int j = i + 1; j < x; j ++){
            if((th[i].ed >= th[j].st && th[i].ed <= th[j].ed)|| (th[j].ed >= th[i].st && th[j].ed <= th[i].ed)){
                th[i].ed = max(th[i].ed, th[j].ed);
                th[i].st = min(th[i].st, th[j].st);
                th[j].fou = true;
            }
          }
          th2[k].ed = th[i].ed;
          th2[k ++].st = th[i].st;
       }
        for(int i = 0; i < y; i ++){
            if(ch[i].fou) continue;
            int st, ed;
        for(int j = i + 1; j < y; j ++){
            if((ch[i].ed >= ch[j].st && ch[i].ed <= ch[j].ed) || (ch[j].ed >= ch[i].st && ch[j].ed <= ch[i].ed)){
                ch[i].ed = max(ch[i].ed, ch[j].ed);
                ch[i].st = min(ch[i].st, ch[j].st);
                ch[j].fou = true;
            }
          }
          ch2[k2].ed = ch[i].ed;
          ch2[k2 ++].st = ch[i].st;
       }
       int k3 = 0;
       for(int i = 0;i < k; i ++){
            int st, ed;
        for(int j = 0; j < k2; j ++){
            st = max(th2[i].st, ch2[j].st);
            ed = min(th2[i].ed, ch2[j].ed);
            if(st <= ed){
                ans[k3].st = st;
                ans[k3 ++].ed = ed;
            }
        }
       }
       int tot = 0;
       for(int i = 0 ;i < k3; i ++){
        if(ans[i].ed - ans[i].st + 1 >= m){
            tot += ans[i].ed - ans[i].st + 2 - m;
        }
       }
       cout << tot << endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值