0-1背包-uva562-Dividing coins

Dividing coins

Description

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input 

A line with the number of problems  n , followed by  n  times:
  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of  n  lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

  
  
2
3
2 3 5
4
1 2 4 6
Sample Output 

  
  
0
1


题意:一袋装有面值1分~500分的硬币,现在要你分成两半,使它们的差值最小

思路:分成两半,要么正好一人一半,要么有一个人小于平均值,另一个人大于平均值

转化为0-1背包问题,背包容量为平均值,运用0-1背包知识,将背包尽量装满,则差值为sum-dp[sum/2]-dp[sum/2].


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
    int n,i,m,sum,a[105],j,dp[50000];
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        memset(dp,0,sizeof(dp));
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        for(i=1;i<=m;i++)
        {
            for(j=sum/2;j>=0;j--)
            {
                if(j-a[i]>=0)
                dp[j]=dp[j]>dp[j-a[i]]+a[i]?dp[j]:dp[j-a[i]]+a[i];
            }
        }
        printf("%d\n",sum-2*dp[sum/2]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值