POJ-2184-01背包变形-Cow Exhibition

Cow Exhibition

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

Source

USACO 2003 Fall
题意:每头牛有smart值和funness值,求出在smart值的和>0&&funness值>0的情况下,smart值和funness值的总和最大。
分析:转化成01背包问题,每头牛选不选就相当于每件物品选与不选,把牛的smart值看做体积,funness看做价值,则对应dp[j]表示前i件物品放入到体积为j的背包里所达到的最大价值
由于有的体积值为负,将背包容量扩大100000,dp[100000]=0就相当于体积不为负时的dp[0]=0,表示
体积为0的背包里所达到的最大价值为0.

//dp[j]表示前i件物品放入到体积为j的背包里所达到的最大价值
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxn 210000
using namespace std;

int dp[maxn];
int main()
{
    int i,n,S[105],F[105],j,sum;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<maxn;i++)
        dp[i]=-maxn;
        dp[100000]=0;
        sum=100000;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&S[i],&F[i]);
            if(S[i]>0)
                sum+=S[i];      //sum为背包的最大容量
        }
        for(i=0;i<n;i++)
        {
            if(S[i]>=0)
            {
                for(j=sum;j>=S[i];j--)
                {
                    dp[j]=max(dp[j],dp[j-S[i]]+F[i]);
                }
            }
            else
            {
                for(j=0;j<=sum;j++)
                {
                    dp[j]=max(dp[j],dp[j-S[i]]+F[i]);
                }
            }
        }
        int maxx=0;
        for(i=100000;i<=sum;i++)
        {
            if(dp[i]>=0&&maxx<dp[i]+i-100000)
            {
                maxx=dp[i]+i-100000;
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值