POJ3254 Corn Fields 状态压缩DP

第二道状态压缩DP,虽然不难,但还是想了很久。
递推方程 dp[s][i] =Σ dp[s'][i-1]   dp[s][i]表示第i行状态为s时一共有多少种方案,从第一行开始向下递推。
这里要注意 可以用一个数组先把每一行中符合要求的情况全部记录,这样可以有效减少状态,和循环。另外题目要求我们取模,这里要注意。
 
Corn Fields

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 4284

 

Accepted: 2253

Description

Farmer John has purchased a lush new rectangular pasture composed of M byN (1 ≤M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
 
using namespace std;

#define mod  100000000

int n,m;
int begin[15],s[1<<13],top;
int dp[1<<15][15];

bool jud1(int x)         //用于判断是否相邻位置有1 
{
	if(x&(x<<1)) return false;
	return true;
}

bool jud2(int x,int i)   //用于判断是否不能放牧的位置被放牧了。 
{
	if(x&begin[i]) return false;
	return true;
}

void init()              //初始化所有合法状态 
{
	memset(dp,0,sizeof(dp));
	top=0;
	for(int i=0;i<(1<<m);i++)
		if(jud1(i)) s[top++]=i;
}

void solve()
{
	int tmp;
	for(int i=0;i<n;i++)
	{
		begin[i]=0;
		for(int j=0;j<m;j++)
		{
			scanf("%d",&tmp);
			if(tmp==0)
				begin[i]|=(1<<(m-j-1));
		}	
	}
	init();
	for(int i=0;i<top;i++)
		if(jud2(s[i],0)) dp[s[i]][0]=1;
	for(int i=1;i<n;i++)
	{
		for(int j=0;j<top;j++)
		{
			if(!jud2(s[j],i)) continue;
			for(int k=0;k<top;k++)
				if(jud2(s[k],i-1) && !(s[k]&s[j])) dp[s[j]][i]=(dp[s[j]][i]+dp[s[k]][i-1])%mod;
		}
	} 
	int ans=0;
	for(int i=0;i<top;i++)
		ans=(ans+dp[s[i]][n-1])%mod;
	printf("%d\n",ans);	
}

int main()
{
	while(~scanf("%d%d",&n,&m))
		solve();
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值