HDU 1021 Fibonacci Again(斐波那契数列+mod规律)

                                     Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50499    Accepted Submission(s): 23907
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 
Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 
Sample Input
  
  
0 1 2 3 4 5
 
Sample Output
  
  
no no yes no no no
 
题解:斐波那契数列+mod(3)==0,则输出yes,否则输出no。

我写的超时:
#include<iostream>
using namespace std;
int f(int n){
	int s;
	if(n==0)
	s=7;
	else if(n==1)
	s=11;
	else
	s=f(n-1)+f(n-2);
	return s;
}
int main()
{
	while(1){
		int n,s;
		cin>>n;
		s=f(n);
		if(s%3==0)
		cout<<"yes"<<endl;
		else
		cout<<"no"<<endl;
	}
}

还是超时:
#include<cstdio>
#include<iostream>
using namespace std;
#define maxx 1000000
long long f[maxx];
int main()
{
	long n;
	
	while(1)
	{
		scanf("%d",&n);
		f[0]=7;f[1]=11;
		for(int i=2;i<=n;i++){
			f[i]=f[i-1]+f[i-2];
		}
		if(f[n]%3==0)
			printf("yes\n");
			else
			printf("no\n");
	}
	return 0;
}

AC代码:
#include<cstdio>
int main()
{
	int f1,f2,fn,i,n;
	
	while (scanf("%d",&n)==1)
	{
		f1=7,f2=11;
		for (i=2;i<=n;i++)
		{
			fn=(f1+f2)%3;
			f1=f2%3;
			f2=fn%3;
		}
		if (fn%3==0)
		{
			printf("yes\n");
		}
		else
		{
			printf("no\n");
		}
	}
}


原来。。。。。

这里n取值为3,则可将公式条件演变为:

综上所述,可得到以下对应关系:F(0)= 1, F(1) = 2, F(n) = ( F(n-1) + F(n-2)  )( mod 3) (n>=2).

index  0  1  2  3  4  5  6  7  8  9  10  11  12  13

value  1  2  0  2  2  1  0  1  1  2   0   2   2  1

print  no no yes no  no no yes  no  no  no  yes  no  no  no

这样我们就得到了如下规律:从第2个开始每隔4个循环一次。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值