hihocoder #1234 : Fractal 北京赛区(2015)网络赛 (找规律)

#1234 : Fractal

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述


This is the logo of PKUACM 2016. More specifically, the logo is generated as follows:

1. Put four points A0(0,0), B0(0,1), C0(1,1), D0(1,0) on a cartesian coordinate system.

2. Link A0B0, B0C0, C0D0, D0A0 separately, forming square A0B0C0D0.

3. Assume we have already generated square AiBiCiDi, then square Ai+1Bi+1Ci+1Di+1 is generated by linking the midpoints of AiBi, BiCi, CiDi and DiAisuccessively.

4. Repeat step three 1000 times.

Now the designer decides to add a vertical line x=k to this logo( 0<= k < 0.5, and for k, there will be at most 8 digits after the decimal point). He wants to know the number of common points between the new line and the original logo.

输入

In the first line there’s an integer T( T < 10,000), indicating the number of test cases.

Then T lines follow, each describing a test case. Each line contains an float number k, meaning that you should calculate the number of common points between line x = k and the logo.

输出

For each test case, print a line containing one integer indicating the answer. If there are infinity common points, print -1.

样例输入
3
0.375
0.001
0.478
样例输出
-1
4
20
题解:现要在x为0~0.5之间作一条垂线x=k,问该垂线与标识有几个交点,当有无穷个交点时,直接输出"-1"。
输出"-1"的情况就是垂线与小正方形的边重合;此外,越往内,每经过一个具有垂直于x轴的边的正方形,都会增加4个交点。

#include<bits/stdc++.h>
using namespace std;
double f[1010];
void init()
{
	f[0]=0;
	f[1]=0.25;
	for(int i=2;i<1010;i++){
	//每条垂直边的横坐标都等于(前一条垂直边的横坐标 + 0.5)/2
		f[i]=(0.5+f[i-1])/2;
	}
}
int main()
{
	int t;
	init();
	cin>>t;
	while(t--){
		double x;
		cin>>x;
		int i=0;
		while(x>f[i]){
			i++;
		}
		if(x==f[i])cout<<-1<<endl;
		else cout<<i*4<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值