XCode升级之后插件无法使用的解决方案

原创 2015年07月06日 21:08:04


问题描述

——————————————————————————————————————————————————————————————————————————————

     在 ios 的开发中,为了在较新的 ios 版本上进行开发,我们需要不断地对 xcode 进行升级。如果大家在 xcode 中使用了插件那一定会遇到这个问题,将 xcode 升级到较新的版本后,以前的插件都无法使用了,对于插件de "重度使用者",遇到这个问题肯定是“惊呆”发火了!


问题出现的原因

—————————————————————————————————————————————————————————————————————————————

     在这里不打算详细地剖析具体的原因,感兴趣者请自行搜索,但主要的原因是 xcode 升级之后整个软件的签名(uuid)改变了,从而导致插件无法使用。



解决方法

—————————————————————————————————————————————————————————————————————————————

     那么如何解决这个问题呢?简单,只需在终端中输入一下命令即可,至于命令具体的原理则是将新版本的 xcode 签名加到相应的文件中。


find ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins -name Info.plist -maxdepth 3 | xargs -I{} defaults write {} DVTPlugInCompatibilityUUIDs -array-add `defaults read /Applications/Xcode.app/Contents/Info.plist DVTPlugInCompatibilityUUID`



版权声明:本文为博主原创文章,未经博主允许不得转载。

升级Xcode到6.1之后使用iPhone6真机测试cocos2d-x报错不支持arm64的解决方案(转)

转载请注明出处http://blog.csdn.net/wjlpld/ 谢谢大家         最近收入iPhone6之后将Xcode顺便升级到6.1版本,编译cocos2d-x 3.2的Hello...

升级Xcode到6.1之后使用iPhone6真机测试cocos2d-x报错不支持arm64的解决方案,Undefin ...

转载请注明出处http://blog.csdn.net/wjlpld/ 谢谢大家          最近收入iPhone6之后将Xcode顺便升级到6.1版本,编译cocos2d-x 3.2...

升级Xcode到6.1之后使用iPhone6真机测试cocos2d-x报错不支持arm64的解决方案,Undefined symbols for architecture arm64 错误

转载请注明出处http://blog.csdn.net/wjlpld/   谢谢大家 最近收入iP
  • wjlpld
  • wjlpld
  • 2014年10月23日 16:42
  • 2204

ios开发之升级到Xcode7之后插件无法使用与不小心点击Skipbundle的解决办法

问题描述: 1.升级到Xcode7之后VVDocumenter-Xcode,OMColorSense,KSImageNamed等一系列的插件失效 2.不小心误点了 Skipbundle 导致 Xcod...

iOS开发---Xcode7升级之后插件无法使用或者不小心点击Skipbundle的解决办法

Xcode 升级到7之后VVDocumenter-Xcode,OMColorSense,KSImageNamed等一系列的插件失效的解决办法,以及不小心误点了 Skipbundle 的解决办法...

iOS开发-工具:Xcode7升级之后插件无法使用与不小心点击Skipbundle的解决办法

转自http://www.bubuko.com/infodetail-1140233.html 小伙伴们在升级了 Xcode7 之后有些插件不能使用了.现在提供如下解决办法: 1. 首先查...

升级Xcode7之后VVDocumenter-Xcode等插件无法使用的解决办法

问题的原因是:苹果要求加入UUID证书从而保证插件的稳定性。 看了很多资料后,现将解决办法分享如下:一、查找Xcode的UUID在终端执行以下命令: defaults read /Applicat...

升级Mac os x 10.10+xcode6.1之后,Cocoapods出现问题的解决方案

在升级Mac OS X 10.10+Xcode 6.1之后,Cocoapods的依赖库管理也相应的进行了升级。目前最新的Release版本是 0.34。在之前的版本中,进行库更新和管理时,会遇到如下错...

升级Xcode7之后安装的插件不能使用的解决办法

随着 Xcode7.2的发布,配合 swift2.1,诸多开发者都已经将 xcode 升级到 xcode7.2,作为提高开发效率,我们都会安装各种各样的xcode 的第三方插件,但是诸多童鞋都会遇到,...

每次Xcode升级后,所有的插件都使用不鸟的解决方案Xcode7.2 Xcode7.1

本篇博客,主要是为了方便以后解决插件失效后,迅速让插件又活过来。 1.    先关闭当前Xcode. 2. 查看当前 Xcode 的 UUID,在终端执行 defaults read...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:XCode升级之后插件无法使用的解决方案
举报原因:
原因补充:

(最多只允许输入30个字)