Light OJ 1138:Trailing Zeroes (III)【二分+求阶乘中某质因子的幂】

 Trailing Zeroes (III)
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

求阶乘N!末尾零的个数:

int numOfZero(int n)
{
	int num = 0, i;
	for(i=5; i<=n; i*=5)
	{
		num += n/i;
	}
	return num;
}
AC-code:

#include<cstdio>
long long n;
long long qiu(long long x)
{
	long long num=0;
	for(long long i=5;i<=x;i*=5)
		num+=x/i;
	return num;
}
long long solve(long long l,long long r)
{
	long long mid=(l+r)/2;
	long long tmp=qiu(mid);
	if(l==r)
	{
		if(tmp==n)
			return mid;
		else
			return -1; 
	}
	if(tmp<n)
		return solve(mid+1,r);
	else if(tmp>n)
		return solve(l,mid);
	else
		return mid;
}
int main()
{
	int t,i;
	scanf("%d",&t);
	for(i=1;i<=t;i++)
	{
		scanf("%lld",&n);
		long long ans=solve(0,1000000000000);
		if(ans==-1)
			printf("Case %d: impossible\n",i);
		else
		{
			while(qiu(ans-1)==n)
				ans--;
			printf("Case %d: %lld\n",i,ans);
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值