HDU 2141~ Can you find it? 还是二分法~~

Can you find it?

Time Limit : 10000/3000ms (Java/Other)   Memory Limit : 32768/10000K (Java/Other)
Total Submission(s) : 274   Accepted Submission(s) : 87
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

纳闷儿的是我注释掉的明明可以减轻程序运行的负担~但实际上确实Wrong answer~注释掉就ac了~~~抓狂

AC-code:

Sample Output
  
  
Case 1: NO YES NO
#include<stdio.h>
#include<algorithm>
using namespace std;
int A[505],B[505],C[505],num[500*500*500+10];
int main()
{
	int l,m,n,i,j,le,k,r,x,s,mid,p=1;
	while(~scanf("%d%d%d",&l,&m,&n))
	{
		for(i=0;i<l;i++)
			scanf("%d",&A[i]);
		for(i=0;i<m;i++)
			scanf("%d",&B[i]);
		for(i=0;i<n;i++)
			scanf("%d",&C[i]);
		
		printf("Case %d:\n",p++);
		scanf("%d",&s);
		int len=0;
		for(i=0;i<l;i++)
			for(j=0;j<m;j++)
				num[len++]=A[i]+B[j];
		sort(num,num+len);
		sort(C,C+n);	
		while(s--)
		{
			k=0;
			scanf("%d",&x);
//			if(x<num[0]+C[0]||x>num[len-1]+C[n-1])
//			{
//				printf("NO\n");
//				continue;
//			}	
			for(i=0;i<n;i++)
			{
				le=0;r=len-1;
				while(le<=r)
				{
					mid=(le+r)/2;
					if(x-num[mid]==C[i])
					{
						k=1;
						break;
					}
					else if(x-num[mid]<C[i])
						r=mid-1;
					else
						le=mid+1;
				}
				if(k)
					break;	
			}
			if(k)
				printf("YES\n");
			else
				printf("NO\n");	
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值