hdu 1317 XYZZY 国产SPFA算法AC,,题目输入部分真特么难懂。。内有解析

154 篇文章 1 订阅
50 篇文章 0 订阅

XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3017    Accepted Submission(s): 824


Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.
 

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".
 

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1
 

Sample Output
  
  
hopeless hopeless winnable winnable
 
这道题属于中等难度的,一般人都有思路,但是可能一次AC有点困难。
我先说下这道题的输入输出,首先输入一个整数n代表房间数目,下面的n行全是各个房间的信息,比如说第i行,第一个数字代表的是当前房间的能量值,第二个数字代表的是有m个门与其他房间相连,后面的m个数字的意思是,可以从第i房间到达数字所代表的房间。
我看了好久才明白。
要注意的是,,判断出有正环时,不能直接就输出 winnable, 还要判断能否到达终点。
还要注意的是,到达终点房间,,体能必须大于0,而不是大于等于0。
最后,这道题如果用Floyd预处理一下,判断能否到达终点,再用Bellman-Ford或者SPFA判断是否存在正环,应该更简单点。
    我是纯属蛋疼想练一下国产算法SPFA。
下面是代码:
#include <cstdio>
#include <queue>
#include <cstring>
#define INF 100000000
#define MAX 110
using namespace std ;
int dis[MAX],graph[MAX][MAX] , c[MAX] ;
bool visited[MAX] ;

void init(int n)
{
	memset(visited,false,sizeof(visited)) ;
	memset(c,0,sizeof(c)) ;
	for(int i = 0 ; i <= n ; ++i)
	{
		for(int j = 0 ; j <= i ; ++j)
		{
			graph[i][j] = graph[j][i] = -INF ;
		}
	}
}

void SPFA(int n)
{
	queue<int> que ;
	for(int i = 0 ; i <= n ; ++i)
	{
		dis[i] = -INF ;
	}
	dis[1] = 100 ;
	que.push(1) ;
	while(!que.empty())
	{
		int k = que.front() ;
		que.pop() ;
		visited[k] = false ;
		c[k]++;
		if(c[k]>n)		//存在正环,,则把dis[k]设为INF,同时使他不能再被访问 
		{
			dis[k] = INF ;
			visited[k] = true ;
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			if(graph[k][i] == -INF)
			{
				continue ;
			}
			else if(dis[k]+graph[k][i]>0) 
			{
				if(dis[i]<dis[k] + graph[k][i])
				{
					dis[i] = dis[k]+graph[k][i] ;
					if(!visited[i])
					{
						que.push(i) ;
						visited[i] = true ;
					}
				}
				
			}
			
		}
	}
}

int main()
{
	int n ; 
	while(~scanf("%d",&n) && n!=-1)
	{
		init(n);
		for(int i = 1 ; i <= n ; ++i)
		{
			int w , m , x ;
			scanf("%d%d",&w,&m);
			for(int j = 0 ; j < m ; ++j)
			{
				scanf("%d",&x);
				graph[i][x] = w ;
			}
		}
		SPFA(n) ;
		if(dis[n] > 0)
		{
			puts("winnable");
		}
		else
		{
			puts("hopeless") ;
		}
	}
	return 0 ;
}

与君共勉
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值