A Bug's Life

A Bug's Life

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
输入
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 10000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
输出
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
样例输入
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
样例输出
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


解题报告:种类并查集。


code

方法一:把性别相同的虫子放在同一个集合,然后每读入一对虫子号,判断它们在不在同一集合,在则同性别,不在则继续。

#include<iostream>
#include<stdio.h>
#include<queue>
#include<vector>
#include<stack>
#include<cstring>
#include<algorithm>

using namespace std;

typedef long long ll;
const int MAXN = 10005; /*结点数目上限*/
int pa[MAXN];    /*pa[x]表示x的父节点*/
int rank[MAXN];    /*rank[x]是x的高度的一个上界*/
int gender[MAXN];  // 与i性别相反的虫子号

/*创建一个单元集*/
void make_set(int x)
{
    pa[x] = x;
    rank[x] = 0;
    gender[x]=0;
}

/*带路径压缩的查找*/
int find_set(int x)
{
    if(x != pa[x]){
        pa[x] = find_set(pa[x]);
    }
    return pa[x];
}

/*按秩合并x,y所在的集合*/
void union_set(int x, int y)
{
    x = find_set(x);
    y = find_set(y);
    if(rank[x] > rank[y])/*让rank比较高的作为父结点*/
    {
        pa[y] = x;
    }
    else
    {
        pa[x] = y;
        if(rank[x] == rank[y])
            rank[y]++;
    }
}

int main()
{
  //  freopen("input.txt","r",stdin);
    int t,m,n,k=1;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&m,&n);
        for(int i=1;i<=m;i++){ //初始化
            make_set(i);
        }
        int a,b,flag=1;
        for(int i=0;i<n;i++){
            scanf("%d%d",&a,&b);
            if(!flag) //结果出来之后也要把数据读完
                continue;
            if(find_set(a)==find_set(b)){  //判断两个虫子在不在同一个集合
                flag=0;
                continue;
            }
            if(gender[a]==0) gender[a]=b; //把性别相同的虫子放在同一个集合里
            else union_set(gender[a],b);
            if(gender[b]==0) gender[b]=a;
            else union_set(gender[b],a);
        }
        if(k!=1)
            printf("\n");
        if(flag)
            printf("Scenario #%d:\nNo suspicious bugs found!\n",k++);
        else
            printf("Scenario #%d:\nSuspicious bugs found!\n",k++);
    }
    return 0;
}


方法二:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<sstream>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
#include<set>
using namespace std;
const int MAXN = 10005; /*结点数目上限*/
int pa[2*MAXN];    /*2种动物*/

/*创建一个单元集*/
void make_set(int x)
{
    pa[x] = x;
}

/*带路径压缩的查找*/
int find_set(int x)
{
    if(x != pa[x])
        pa[x] = find_set(pa[x]);
    return pa[x];
}

/*按秩合并x,y所在的集合*/
void union_set(int x, int y)
{
    x = find_set(x);
    y = find_set(y);
    if(x == y) return;
    pa[x]=y;
}

int main()
{
  //  freopen("input.txt","r",stdin);
    int t,n,k,x,y,m=1;
    scanf("%d",&t);
    while(t--){
        /*i~n是男,i+n~i+2*n是女*/
        for(int i=0;i<2*MAXN;i++)
            make_set(i);
        scanf("%d%d",&n,&k);
        int flag=1;
        while(k--){
            scanf("%d%d",&x,&y);
            if(!flag) continue;
            if(find_set(x)==find_set(y)||find_set(x+n)==find_set(y+n)){/*是否是同性*/
                flag=0;
                continue;
            }else{
                union_set(x,y+n);/*男-女*/
                union_set(x+n,y);/*女-男*/
            }
        }
        printf("Scenario #%d:\n",m++);
        if(flag) printf("No suspicious bugs found!\n\n");
        else printf("Suspicious bugs found!\n\n");
    }
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值