B - A Bug's Life

B - A Bug's Life
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 
 

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input

     
     
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output

     
     
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!

Hint

Huge input,scanf is recommended. 
         
 


题意是给你很多对数字,表示这一对数字的性别是相反的,一共只有两种性别,问你会不会其中出现冲突的情况,

例如输入了 1 2 和 1 3 然后又输入了 2 3,很明显就冲突了。


标题给的是并查集,但是看了一下题之后发现1000个点是可以用bfs进行二染色的,如果染色的时候发现了冲突的点那么就直接输入有冲突即可。


注:此题如果在杭电上交要使用C++,如果G++提交会WA。至今不知为什么。

#include"iostream"
#include"cstring"
#include"cstdio"
#include"vector"
#include"queue"

using namespace std;

vector<int> E[2005];
bool vis[2005];
bool flag;
int col[2005];

void bfs(int x)
{
    vis[x] = true;
    queue<int> q;
    q.push(x);
    col[x] = 1;
    while(!q.empty())
    {
        int nn = q.front();
        q.pop();
        int siz = E[nn].size();
        for(int i = 0;i < siz;i++)
        {
            int en = E[nn][i];
            if(vis[en] && col[en] == col[nn])
            {
                flag = true;
                return;
            }
            if(!vis[en])
            {
                vis[en] = true;
                q.push(en);
                if(col[nn] == 1) col[en] = 0;
                if(col[nn] == 0) col[en] = 1;
            }
        }
    }
}

int main(void)
{
    int T;
    scanf("%d",&T);
    for(int cas = 1;cas <= T;cas++)
    {
        flag = false;
        for(int i = 0;i < 2005;i++) E[i].clear();
        memset(vis,false,sizeof(vis));
        for(int i = 1;i <= 2005;i++) col[i] = -1;
        int n,m;
        scanf("%d%d",&n,&m);
        while(m--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            E[a].push_back(b);
            E[b].push_back(a);
        }
        for(int i = 1;i <= n;i++)
        {
            if(!vis[i])
            {
                bfs(i);
            }
        }
        printf("Scenario #%d:\n",cas);
        if(flag) printf("Suspicious bugs found!\n");
        else printf("No suspicious bugs found!\n");
        printf("\n");
    }
    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值