poj 2492(并查集)

A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 20474 Accepted: 6657

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany



题目类型:并查集

题目描述:教授在研究一种虫子,他假设这个虫子只有两种性别,并且只有异性之间才能发生关系。
现在有n只虫子,m条信息。每条信息有a,b。表示a和b发生了性关系。问有没有可疑的虫子(导致他的假设错误的虫子)。


题目分析:与poj 1703一样。


代码如下:


#include <iostream>
#include <stdio.h>
#include <math.h>
#define N 2001
using namespace std;

int f[N];
int rank[N];
int foe[N];
int n;
bool flag;

void makeSet(){
    for(int i = 1; i <= n; i++){
        f[i] = i;
        rank[i] = 0;
        foe[i] = -1;
    }
    flag = false;
}

int findRoot(int x){
    if(f[x] == x){
        return x;
    } else {
        return f[x] = findRoot(f[x]);
    }
}

void merge(int a,int b) {
    int ra = findRoot(a);
    int rb = findRoot(b);
    if(ra != rb){
        if( rank[ra] < rank[rb] ){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[ra] == rank[rb]){
                rank[ra]++;
            }
        }
    }
}


int main()
{
    int t,c = 0;
    scanf("%d",&t);
    while(t--){
        int m,a,b;
        scanf("%d%d",&n,&m);
        makeSet();
        for(int i = 0; i < m; i++){
            scanf("%d%d",&a,&b);
            if(!flag){
                int ra = findRoot(a);
                int rb = findRoot(b);
                if(ra == rb){
                    flag = true;
                } else {
                    if( foe[a] == -1){
                        foe[a] = b;
                    }
                    if( foe[b] == -1){
                        foe[b] = a;
                    }
                    merge(a,foe[b]);
                    merge(b,foe[a]);
                }

            }
        }
        printf("Scenario #%d:\n",++c);
        if(flag){
            printf("Suspicious bugs found!\n");
        } else {
            printf("No suspicious bugs found!\n");
        }
        printf("\n");
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值