关闭

studio 编译报错:compileSdkVersion 'android-24' requires JDK 1.8 or later to compile.

标签: androidjdk
347人阅读 评论(0) 收藏 举报
分类:

翻译: compileSdkVersion android-24”需要JDK 1.8或更高版本编译。

报错现象如下图:


原因:studio默认选择编译的版本为1.8,而当前jdk环境不是1.8. 

解决方法:

1. 在build.gradle中查看编译版本;


2.查看studio设置,修改studio设置的jdk设置。




方法一:修改JDK,更改为JDK1.8,

方法二:更改studio编译版本。如下图:







0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:3776次
    • 积分:131
    • 等级:
    • 排名:千里之外
    • 原创:9篇
    • 转载:0篇
    • 译文:0篇
    • 评论:11条
    文章分类
    最新评论