POJ 1003 Hangover

Hangover
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110237 Accepted: 53844

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2+ 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2+ 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source


水题。

题目意思是求使那个等式成立的最小n.

1.最简单的做法是暴力枚举,因为数据量很小。

2.在1上优化的话就是记忆化搜索,初始状态为-1,然后将每一个n对应的值算出来,因为是累加和,所以判断上一个状态是否为-1,如果不是直接返回上一次计算后的值。

3.最常见的做法,因为最大是5.2,当n到300的时候就已经可以了。在1,300之间打表,然后对于每一个c将表里的数据累加判断即可。

4.我的做法,在3的基础上二分。因为等式左边的值会随着n的增大而增大,所以在1,300之间二分即可。因为OJ的测试数据量不大,所以和别的做法时间上差距不大。

但这种方法我个人感觉是很十分优良的。


#include <stdio.h>
#include <algorithm>
#define N 305
using namespace std;
double dp[N];
void gettable()
{
        dp[1]=0.5;
        for(int i=2;i<=300;i++)
                dp[i]=dp[i-1]+1.0/(i+1);
}
int main()
{
        gettable();
        double c;
        while(scanf("%lf",&c)>0&&c)
        {
                int minn=1,maxn=300;
                int mid=(minn+maxn)/2;
                int ans=500;
                while(minn<=maxn)
                {
                        if(dp[mid]<c)
                                minn=mid+1;
                        else if(dp[mid]>=c)
                                maxn=mid-1,ans=min(ans,mid);
                        mid=(minn+maxn)/2;
                }
                printf("%d card(s)\n",ans);
        }
        return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值