POJ 1003 hangover

Hangover
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 124770 Accepted: 60881

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

//题目的意思就是在一张桌子的边缘放置纸牌,取一张纸牌放在圆纸牌的下面,且当上面的纸牌露出桌子边缘的长度为第一张纸牌的1/2时纸牌不会掉下去。。。依次将第三张纸牌放在第二张纸牌的下面,且第二张纸牌露出桌面的长度为第三张纸牌的1/3时纸牌不会掉下去,第i张纸牌占i+1纸牌的1/(i+1)
#include <iostream>
#include <cstdio>
using namespace std;
int main(int argc, const char * argv[]) {
    // insert code here...
    //std::cout << "Hello, World!\n";
    double dis,f,i;
    while(scanf("%lf",&f)==1&&f!=0.0)
    {
        int j;
        dis=0.0;
        for(i=2,j=0;dis<f;i++,j++)//露出桌边的总长度超过给定的数值时纸牌就会掉下去
            dis+=1/i;
        printf("%d card(s)\n",j);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值