POJ 3671 Dining Cows

Dining Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7758 Accepted: 3282

Description

The cows are so very silly about their dinner partners. They have organized themselves into two groups (conveniently numbered 1 and 2) that insist upon dining together in order, with group 1 at the beginning of the line and group 2 at the end. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 2) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it's easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ's job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 112222 or 111122 where the cows' dining groups are sorted in ascending order by their dinner cards. Rarely he might change cards so that only one group of cows is left (e.g., 1111 or 222).

FJ is just as lazy as the next fellow. He's curious: what is the absolute minimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 describes cow i's dining preference with a single integer: Di

Output

* Line 1: A single integer that is the minimum number of cards Farmer John must change to assign the cows to eating groups as described.

Sample Input

7
2
1
1
1
2
2
1

Sample Output

2

Source


题目大意:给一个只有1和2的序列,问要使序列为不降序列,至少修改几次。

方法,显然DP,最后的答案就是n-最长不降子序列长度。

一开始用传统的最长不降子序列的DP做,TLE了。

既然只有1和2,那就可以优化了。

如果a[i]为1,那么只能由1转换过来

如果a[i]为2,那么可以由1转换过来,也可以由2转换过来,取这两种情况的最大值即可。

此题可以用在线算法。


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN=30005;
int a[MAXN];
int dp[MAXN];

int main()
{
        int n;
        while(scanf("%d",&n)>0)
        {
                int c1=0,c2=0;
                for(int i=1;i<=n;i++)
                {
                        scanf("%d",&a[i]);
                        if(a[i]==1)
                                dp[i]=dp[c1]+=1,c1=i;
                        else
                                dp[i]=max(dp[c1],dp[c2])+1,c2=i;
                }
                printf("%d\n",n-max(dp[c1],dp[c2]));
        }
        return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值