poj3671Dining Cows(DP)

题目链接:

题意:

给一个只含有1,2的序列,怎样变换n次使序列成为一个非递减的序列,并且使n最小。

思路:

这道题的数据范围是50000,则肯定承受不了n方的复杂度,所以 只能写O(n)的算法,甚至更小,所以当时想二分,但是不知道怎么写,忽然想到可以枚举每个位置,把每一个位置都当做一个分界点,然后求前半部有多少个2,后半段有多少个1,最后和全部是1和2进行比较,这个问题便得到了解决。

题目:

Dining Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7237 Accepted: 3078

Description

The cows are so very silly about their dinner partners. They have organized themselves into two groups (conveniently numbered 1 and 2) that insist upon dining together in order, with group 1 at the beginning of the line and group 2 at the end. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 2) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it's easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ's job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 112222 or 111122 where the cows' dining groups are sorted in ascending order by their dinner cards. Rarely he might change cards so that only one group of cows is left (e.g., 1111 or 222).

FJ is just as lazy as the next fellow. He's curious: what is the absolute minimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 describes cow i's dining preference with a single integer: Di

Output

* Line 1: A single integer that is the minimum number of cards Farmer John must change to assign the cows to eating groups as described.

Sample Input

7
2
1
1
1
2
2
1

Sample Output

2

Source



代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=30000+10;

int sum1[maxn],sum2[maxn];

int main()
{
    int n,cal1,cal2,tmp,ans;
    while(~scanf("%d",&n))
    {
        cal1=cal2=0;
        ans=INF;
        memset(sum1,0,sizeof(sum1));
        memset(sum2,0,sizeof(sum2));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&tmp);
            if(tmp==1)
                sum1[i]=++cal1;
            else
                sum1[i]=cal1;
            if(tmp==2)
                sum2[i]=++cal2;
            else
                sum2[i]=cal2;
        }
        for(int i=1;i<n;i++)
            ans=min(ans,sum2[i]+(sum1[n]-sum1[i]));
        ans=min(ans,sum1[n]);
        ans=min(ans,sum2[n]);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值