poj - 2406 Power Strings 【KMP】

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 45224 Accepted: 18873

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


题意:

求出字符串中最小的循环单元。

思路:

KMP算法中的next数组提供了方法,这个博客中介绍了方法点击打开链接

#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
//#define LOACL
#define space " "
using namespace std;
typedef long long LL;
//typedef __int64 Int;
typedef pair<int, int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double Pi = acos(-1.0);
const int MOD = 1e9 + 7;
const int MAXN = 1e6 + 10;
int Next[MAXN];
char str[MAXN];
void get_next(int l) {
    int i = 0, j = -1;
    Next[0] = -1;
    while (i < l) {
        if (j == -1 || str[i] == str[j]) {
            i++; j++; Next[i] = j;
        }
        else j = Next[j];
    }
}
int main() {
    while (scanf("%s", str) != EOF) {
        if (str[0] == '.') break;
        int len = strlen(str);
        get_next(len);
        int c = len - Next[len];
        if (len%c) {printf("1\n");}
        else printf("%d\n", len/c);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值